Jump to content




Swarm Miner - Quarry Up Where You Want. Version 2.0

turtle wireless

215 replies to this topic

#141 HeffeD

  • Members
  • 61 posts

Posted 29 October 2013 - 05:03 PM

View Postwojbie, on 29 October 2013 - 04:07 PM, said:

OK i already found where that bug is from - working on fixing it.

Also side note
["id"]=0?
That turtle id is 0? interesting coincidence.

Yes, the turtle is ID 0. I didn't think of that. Maybe he's a ghost? :lol:

#142 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 29 October 2013 - 05:07 PM

View PostHeffeD, on 29 October 2013 - 05:03 PM, said:

Yes, the turtle is ID 0. I didn't think of that. Maybe he's a ghost? :lol:

Spooky. Also - bug fixed.



UPDATE:v1.4.1

Changes:
  • Added additional Situational Awareness code - turtle recognizes if it makes a mistake and carries on
  • Refined anti-sector-colision code - again
  • Added layer info to scanner screen
  • Added cycle and recovery files to disk - those are deployer/collector code that i am working on - operational right now but untestet/lacks UI.
  • Tweaked Top Level Overwrite and Beacon - now broken scanners will emit Beacon Signal too.
  • Bugfixes
Run
 disk/startup update 
on your swarminer disk to download latest version

Then

Run
 disk/startup update 
on your swarminer disk to download latest version cause update code got updated.

Edited by wojbie, 09 November 2013 - 07:00 PM.


#143 karlsen

  • Members
  • 3 posts

Posted 29 October 2013 - 05:29 PM

I love seeing all these updates wojbie! Keep it up!

#144 HeffeD

  • Members
  • 61 posts

Posted 29 October 2013 - 10:49 PM

With the latest update, I quite often see turtles going back over a layer they've just mined. :unsure:

No errors or anything, I just look down and see a turtle mining air.

Edit: Hmmm... You definitely want to back up your worlds folks. :o :(

I just looked in on my quarry and all of the turtles had stopped what they were doing. When going to investigate, I found that I couldn't interact with them at all. They were completely locked up, as was the scanner and my gps array. After restarting the game, every computer in my world is dead.

I didn't even know such a thing was possible. :huh:

#145 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 30 October 2013 - 04:37 AM

:blink:
OK for repeats i know the reason - forgot to remove part of debug code - fixing.

Second one sounds familiar but i don't remember where i heard that - it was some kind of computercraft bug i think.
I am 90% sure thats not entirely my fault. :mellow:

Anyways fixed - i hope.

Run
 disk/startup update 
on your swarminer disk to download latest version

2 Times if you can - update code got updated again

#146 HeffeD

  • Members
  • 61 posts

Posted 30 October 2013 - 12:33 PM

I just watched two turtles get into a stalemate. One was facing the other one, while the second one was facing to the side. Eventually, one of the turtles placed a loot enderchest, then the fuel chest and fueled itself, then routed around the other one. Then the other turtle started to move, but then placed a piece of cobblestone below it and ejected all of it's inventory onto the ground, including both enderchests. It currently only has a partial stack of cobblestone in slot 1. (Where the loot chest should be)

So apparently, it either picked the wrong slot for the loot chest, or cobblestone somehow got into the slot reserved for the loot chest. Of course that doesn't explain why it chose to dump the fuel chest along with everything else... :huh:

Normal turtle
CC 1.53
Current log of the turtle that took a dump on the floor.
{["layer"]=0,["loc"]={["x"]=4,["z"]=3,},["pos"]={["y"]=2,["x"]=1536,["z"]=-592,["zd"]=1,["xd"]=0,},["run"]=true,["fuel"]=253,["id"]=17,}

Removing the cobblestone and replacing the enderchests where they should be allowed the turtle to continue on its way.

Sorry, I was so surprised at the tutle placing the cobblestone and dumping its inventory, I didn't think to go and look at the scanner to see if the emergency beacon had triggered or anything. :(

Edit: this is using the latest code update, and I ran the update twice as you suggested.

Edit 2: Turtles 17 and 18 are attempting to mine the same sector. These were likely the two that were in a stalemate previously. At least I know 17 was one of them, because it's the turtle I gave the current log for above. 17 is currently following 18 around. Even moving down to the next layer.

ID 17 current log:
{["layer"]=6,["loc"]={["x"]=4,["z"]=3,},["pos"]={["y"]=77,["x"]=1535,["z"]=-584,["zd"]=1,["xd"]=0,},["run"]=true,["fuel"]=231,["id"]=17,}

ID 18 current log:
{["layer"]=6,["loc"]={["x"]=4,["z"]=3,},["pos"]={["y"]=77,["x"]=1535,["z"]=-584,["zd"]=1,["xd"]=0,},["run"]=true,["fuel"]=225,["id"]=18,}

The scanner also reports them as both mining the same sector.

#147 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 30 October 2013 - 12:51 PM

OK for first one i have no idea. :blink:
Sounds like turtle forgot it was supposed to use loot chest ... then placed cobble as loot chest... ok that is wierd...
Will look into that but honestly i have no idea where to start.... probably in refueling code i guess.

As for second one sounds like i need to refine anti-colision code some more - they seem to calculate it wrong again.
Well scanner part worked correctly so thats a plus. :D

EDIT: Updated small bugfix - not related to your bugs thought.

#148 HeffeD

  • Members
  • 61 posts

Posted 30 October 2013 - 03:15 PM

View Postwojbie, on 30 October 2013 - 12:51 PM, said:

Well scanner part worked correctly so thats a plus. :D

Yes, and I forgot to mention, I ended up terminating and restarting turtle 17, because I couldn't see the point of it following the other turtle to the bottom of the quarry because it obviously wasn't correcting itself.

When I terminated the program, I went to look at the scanner and it did list ID 17 as ERROR, so the emergency beacon seems to be working in the case of an unexpected termination. :)

#149 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 30 October 2013 - 03:38 PM

Just an update i may be silent for next two days no worries program is still worked on.
I am simply Rubber duck debugging the program right now - it got a bit cluttered.
Posted Image

#150 HeffeD

  • Members
  • 61 posts

Posted 31 October 2013 - 11:35 AM

Yeah, there's something strange going on with enderchests sometimes.

I didn't see what had happened, but I checked on my quarry and found a turtle stalled in the air. Both enderchests were missing. There was some cobblestone in slot 3 and some dirt in slot 4, but that was all that was in its inventory.

So if it was a case like the one I previously reported where the turtle dumped all of its inventory by trying to place it in a piece of cobblestone, that doesn't explain why slots 1 and 2 were empty, with some cobblestone and dirt in slots 3 and 4. I would have expected like the other time, to have some item that wasn't the loot chest in slot 1, with all of the rest of the inventory ejected.

#151 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 02 November 2013 - 03:47 PM

UPDATE: v2.0

Changes:
  • Removed OpenPeripheral requirement for emptying chests - i realized i can code it smarter.
  • If OpenPeripheral installed will recognize monster_spawner and not mine it. Along with all other peripheral blocks ( chests excluded.)
  • Whole Program Got reread and cleanup
  • Removed lots of small bugs/applied tweaks.
  • Added Screen Saver on turtles that lovers amount of operations each turtle does.
  • Added Monitor Support to Scanners - if you place monitor next to scanner it will automatically display statistical data about: amount mined/amount currently in mining/amount to mine. It also auto detects Monitor Size and writes in largest font possible.
  • Rewrote fuel handling code... again. (I can't seem to be able to stop messing with it)
  • Added Logo. Just to stroke my ego.
  • Something i am forgetting right now should be here.
Run
 disk/startup update 
on your swarminer disk to download latest version

#152 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 03 November 2013 - 09:39 AM

UPDATE: v2.1

Changes:
  • Bugfix
  • Added fastgps utility program to floppy - allows for fast gps computer setup. It scans for coords from gps in area if not get them asks them. Then it creates basic gps host program that spreads gps signal. If there is startup file on computer it moves it into startup.backup[nr] file. Can be also used directly from pastebin on v1.6.2 and after that by simply calling pastebin run 4xanbDSX for even faster speeder setup.

Run
 disk/startup update 
on your swarminer disk to download latest version

#153 HeffeD

  • Members
  • 61 posts

Posted 09 November 2013 - 01:48 PM

View Postwojbie, on 02 November 2013 - 03:47 PM, said:

If OpenPeripheral installed will recognize monster_spawner and not mine it. Along with all other peripheral blocks ( chests excluded.)

I haven't had a chance to try version 2.0 yet, but this functionality was in the previous version as well. After my last quarry was complete, I was surprised to see a zombie spawner floating inside the cleared area.

This makes it very easy to build mob farms around the spawners. :)

#154 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 09 November 2013 - 02:35 PM

View PostHeffeD, on 09 November 2013 - 01:48 PM, said:

View Postwojbie, on 02 November 2013 - 03:47 PM, said:

If OpenPeripheral installed will recognize monster_spawner and not mine it. Along with all other peripheral blocks ( chests excluded.)

I haven't had a chance to try version 2.0 yet, but this functionality was in the previous version as well. After my last quarry was complete, I was surprised to see a zombie spawner floating inside the cleared area.

This makes it very easy to build mob farms around the spawners. :)
Would you believe it I found out exactly same way? I was amazed that open_peripherals adds peripheral to mob_spawner ;D O well more power to me!!

#155 Zierk11001

  • Members
  • 5 posts

Posted 09 November 2013 - 06:01 PM

I download the file from pastebin, startup from disk and after putting in the coords for the gps host i get the following error:

scanner:86: No such method isWireless


@scanner:86 - Line reads:
if peripheral.call(i,"isWireless") then




Can someone help please?

Edited by Zierk11001, 09 November 2013 - 06:05 PM.


#156 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 09 November 2013 - 06:04 PM

What version of ComputerCraft are you using?
Do you have any ComputerCraft peripherals installed? If yes what kind?
Cause in vanilla ComputerCraft this should not bug this way.

#157 Zierk11001

  • Members
  • 5 posts

Posted 09 November 2013 - 06:28 PM

View Postwojbie, on 09 November 2013 - 06:04 PM, said:

What version of ComputerCraft are you using?
Do you have any ComputerCraft peripherals installed? If yes what kind?
Cause in vanilla ComputerCraft this should not bug this way.

Using stock FTB Mindcrack 8.3.2. not sure which cc version it is. I have a wireless modem installed but not sure about the other peripherals sorry :x

#158 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 09 November 2013 - 06:33 PM

Can you post a screen-shot of problematic computer for me? Because that bug could not happen in normal circumstances.
What peripherals are at this moment connected to computer? just wireless modem?

#159 Bomb Bloke

    Hobbyist Coder

  • Moderators
  • 7,096 posts
  • LocationTasmania (AU)

Posted 09 November 2013 - 06:33 PM

That'll be CC 1.5 on Minecraft 1.4.7.

#160 Wojbie

  • Members
  • 630 posts
  • LocationKinda lost

Posted 09 November 2013 - 06:38 PM

Ahhh that explains it - back then modems didn't have that method... ehh i will look into making it backwards compatible.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users