Jump to content

Turtle Architect v2.0, the ULTIMATE turtle planning/construction/3D-printer software.

150 replies to this topic

#141 WeissPure

  • New Members
  • 1 posts

Posted 27 June 2016 - 05:13 PM

I seem to have an issue on both my ftb infinity server and a test world running just computercraft turtle architect but I can't seem to get the scan function to work, I followed the tutorial and it just breaks the blocks and no matter the material making no note of it, the blueprint block updates the scan block to a white block, I've assigned colours and slots with the same materials but I can't seem to create a blueprint.

Is this a bug or am I just missing something?

#142 CometWolf

  • Members
  • 1,283 posts

Posted 27 June 2016 - 08:56 PM

To be honest, the turtle scanning feature was something i implemented for fun which was never throughly tested as it had little use to me personally. It seems some subsequent revisions to it and the way construction was handled broke it, which in turn i never noticed as i never used it. I've deployed some fixes, and based on some light testing it appears to be in working order now. It's functinality might be somewhat unclear though, so i'll go ahead and jot down some info on it incase you're interested.
When there's blocks marked for scanning on your blueprint, the turtle will only do the scanning and no building, regardless of any other blocks.
Any block not found in the slots selected for scan, will be marked with an "X" (the break block marker).
Any blocks scanned which are subsequently found in one of the scan slots, will be given it's color depending on the slot it's in.

Do keep me posted if you run into any issues, because as i said, i only did some light testing so it might still not be working correctly.
Also, i forgot to mention that i stumbled upon a bug in the turtle API i use aswell, so you'll need to delete that (run "rm cTurtle" in the main console) so it's redownloaded.

Edited by CometWolf, 27 June 2016 - 08:58 PM.

#143 HexaNitro

  • New Members
  • 1 posts

Posted 27 September 2016 - 09:23 PM

So I've been searching around for a turtle builder program that can work with what I've already developed for creating complex shapes, and I think this might be the ticket.

Will the coding feature of this program allow me to iterate through each vertical layer and create an array of x and y value pairs denoting the location of each block to be placed on that layer?

What I have now is a for loop from the ground elevation up to the height of my desired tower. For each new layer, it calculates a new radius based on an approximation of the vail, or the projection of the vertical face. With this radius, a circle is approximated and the coordinates are added to the array if the x and y values fall within the circle outline.

I've pasted what I have so far to pastebin here: http://pastebin.com/u3N6Rsnf

Can someone much smarter than I am figure out how to tweak this so that it works with the building code of this project? Thanks!

#144 Kaito Kid

  • Members
  • 3 posts

Posted 19 October 2016 - 03:43 AM


I have recenly tried using Turtle Architect in my server. First of all, I have to say that I am very impressed by the work that has been put into this tool. Good job!

I have ran into a problem when I reach the part where I am trying to actually build my blueprint. Maybe I am missing something.

My turtle is an advanced turtle with a shovel equipped (This is a fairly new world, and I didn't find enough diamond to make a pickaxe yet, but I wanted the turtle to be able to remove blocks. I'm trying to build high in the air anyway so it shouldn't matter in this case)

When I try to build a blueprint, no matter which, it first asks me a bunch of questions (ender chest, break blocks, auto resume, etc). This seems to be normal, and matches what's written in the tutorial. After that, nothing happens. After the last popup (auto-resume), it just goes back to the blueprint editor, with no error or success message, and the turtle doesn't do anything.

I have tried to gather as much information as possible to help you figure it out, so here's what I have:

The program seems to crash for some reason on line 477 in Functions/Turtle.lua. The line is "local function moveTo(nL,nX,nZ,skipCheck)"

Posted Image

I have obtained this information through custom log messages added in your code. No code after this line is ever reached.
I have tried debugging a little, and from what I've seen, nL, nX and nZ seem to be nil (I haven't checked "skipCheck", but it also could be nil).
I don't really understand your code perfectly (it's huge lol), and I'm not a pro in lua, so I am not sure about the following, but nL, nX, nZ and skipCheck do not seem to be initialized until later on, on line 546, when you use them as iterators.

Posted Image

So basically, turtle won't build anything for me for some reason, and my Turtle Architect version is up-to-date. I have tried debugging but failed miserably.

Do you have any idea what's wrong?

Extra information:
My turtle currently has no GPS, but I manually added its coordinates when it asked me, and for the purpose of testing, the turtle is flying very high in the air and has plenty of every blocks it needs. There isn't anything that could block it.
Infinite fuel is turned on.
The "Goto" and "Turn" buttons in the "Tu" menu in the editor seems to work just fine.

Edited by Kaito Kid, 19 October 2016 - 01:54 PM.

#145 CometWolf

  • Members
  • 1,283 posts

Posted 19 October 2016 - 03:13 PM

That is strange, any chance you could upload the build file (blueprint)? A for effort, but line 477 is a function definition, so it won't execute that code before the function is called 😜 Been awhile since i've used this program myself tbh, but i'll fire it up later and have a look aswell. Also, if you want to make debugging a little easier on yourself you can disable the minify feature during install(it removes indentation). To do so you'll have to specify a path followed by a second argument "-t"

Edited by CometWolf, 19 October 2016 - 03:17 PM.

#146 Kaito Kid

  • Members
  • 3 posts

Posted 20 October 2016 - 03:14 AM

Damn, now I feel dumb. The word function is right there. I must have been tired. I've debugged the rest (after the end of that function block), and I'm not sure what lines should or should not have been hit, but the code reaches the end of "function build(blueprint, auto)" without crashing.

I've attached the blueprint I am trying to build, but as I've said, it doesn't seem to work with any blueprint. Even a simple brown square (brown linked to dirt in slot 1) won't work. I've also tried all three blueprint importation options (importing from the main computer through pastebin, importing through file copy and creating the blueprint directly inside the turtle), and I've seen no difference.

Thank you for replying quickly :D

Here are the files. i'm not sure which one is the actual blueprint, they all seem to contain useful data.


Edited by Kaito Kid, 20 October 2016 - 01:19 PM.

#147 CometWolf

  • Members
  • 1,283 posts

Posted 20 October 2016 - 05:44 PM

Looking over this old code is a lesson in why you should always comment code haha... Anyways, turns out i messed up while implementing the scan function, should've noticed that myself tbh. To determine wether the turtle was supposed to scan or not, i checked if the scan table existed, which as it turns out it always does, therefore the turtle was always in scan mode. I've corrected this now, so if you just open the se (settings) tab in the program and hit update you should be good to go.

#148 Kaito Kid

  • Members
  • 3 posts

Posted 20 October 2016 - 08:32 PM

It works perfectly, thank you very much!

I'm wondering how come such a great program is not used more? surely someone would have ran into that problem faster?

#149 CometWolf

  • Members
  • 1,283 posts

Posted 21 October 2016 - 10:27 AM

Personally i like to think it's because it's quite overwhelming. It's safe to say i created the tutorial far too late, leaving most users somewhat at a loss on how to use it. Also wasn't always as feature rich. When i initially released it, it was quite a different program. I started from scratch a few months later though, and the end result is what it is today. Eitherway though, i get my times worth using it whenever i play Minecraft so im happy with it. Always building my super structures in a day or 2 haha.

#150 ovadex

  • Members
  • 3 posts

Posted 20 July 2019 - 04:36 AM

I'm loving this program so much, just wish I could use the ender chest function. I'm on a 1.12.2 server without extra utilities so it doesn't work.

I also saw in an earlier post that there was a way to change the origin position but I guess that was removed at some point. that would have been helpful for some structures I want to make. Like at the end of a bridge have it build the structure so the door is in the right spot.

Amazing work though.

#151 Pyeroh

  • Members
  • 5 posts

Posted 23 September 2021 - 01:09 AM

In case anyone is still using this program to plan and build with turtles, I updated it a bit, mainly to use the keys API (instead of hardcoded key codes), so one can use shortcuts or edit starting positions. It's available here on Github, and can be installed with
pastebin run KPR84sQC
The rest is exactly the same.

If CometWolf is still around, I can submit a PR instead.

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users