Jump to content




ComputerCraft Beta Versions - Bug Reports


72 replies to this topic

#1 dan200

  • Administrators
  • 542 posts
  • LocationCambridge, England

Posted 28 January 2014 - 12:07 PM

Please use this thread for Bug Reports only.
Please use the Discussions thread for discussion.
Incorrectly placed posts will be deleted or moved.

Bug reports must follow the following format:

VERSION:
The version of ComputerCraft the bug happened in (ie: 1.6pr0)
DESCRIPTION:
A description of what happened
EXPECTED RESULT:
What you expected to happen instead
REPRODUCTION STEPS:
A repeatable, step by step guide on what I need to do to see the bug happen, include example lua code if you can.
SCREENSHOT/VIDEO:
If the bug is graphical, or can be better explained visually, try to include a screenshot or video of the bug happening if you can

Please post a copy of your crashlog, or if one is not available, a copy of your forge log.

Posts that aren't bugs, or that don't follow this format may be removed.
Also: please check somebody else hasn't already posted the same bug before posting.

There are many known bugs in pr0, I'll be checking if people find them to see if you collectively do a good job at testing.

Edited by dan200, 22 February 2015 - 08:51 PM.


#2 dmf444

  • New Members
  • 1 posts

Posted 28 January 2014 - 08:50 PM

VERSION:
1.6pr0
(also in 1.56)
DESCRIPTION:
In a crafty turtle with Applied Energistics installed,
Created a basic processor, but tool is completely used up.

EXPECTED RESULT:
Some durability to be removed, and have tool still in Crafty Turtle.

REPRODUCTION STEPS:
In crafty turtle, (With Applied Energistics installed)
XCX
RGR
XSX
~~~~~
X= Empty
C= Cutting tool
R=Redstone
G= Gold
S= Silicon
~~~~~
Then by typing turtle.craft()
it completely uses everything,
Creating one Basic processor



P.S. Saws from Forge Multipart also have the same problem

Edited by dmf444, 17 February 2014 - 05:40 PM.


#3 oeed

    Oversimplifier

  • Members
  • 2,095 posts
  • LocationAuckland, New Zealand

Posted 04 February 2014 - 03:13 AM

This isn't a make or break bug, but it is fairly significant.

As was discussed in this topic, when using the windowing API performance is significantly reduced.

Quote

This is with windowing api working:
Posted Image
And this is with it gone
Posted Image

So, as you can see the windowing API is performing huge amounts worse than without it. Most people get at least 35 for the total (in CC 1.58).

Edited by oeed, 04 February 2014 - 03:16 AM.


#4 Dog

  • Members
  • 1,161 posts
  • LocationEarth orbit

Posted 22 March 2014 - 01:25 AM

VERSION:
1.6pr7
DESCRIPTION:
Portable computer, inserted into a drive, can 'lose' its ID and become a duplicate of another computer
EXPECTED RESULT:
Retrieve portable computer with it's ID, file system, and hardware configuration - not with another system's
REPRODUCTION:
- Place any portable into a floppy drive that is attached to an advanced computer.
- Reboot the advanced computer
- Remove the portable and check its ID
- Different things can happen. Most often the ID may drop by one value, duplicating an already existing computer. All the peripherals attached to a computer may also be duplicated. Usually the label doesn't change regardless of ID change.

Edited by Dog, 23 March 2014 - 08:46 PM.


#5 cgwheeler96

  • Members
  • 7 posts

Posted 22 March 2014 - 03:42 AM

VERSION:
1.6pr7
DESCRIPTION:
If you use the number keys to switch which slot the pocket computer is in on your hot bar, many strange, unpredictable things happen to the computer on your hot bar. Sometimes it takes multiple attempts to see the result, but sometimes the computer changes ids, looses full functionality, creates a duplicate, disappears entirely, and maybe more things that I haven't seen yet.
EXPECTED RESULT:
to move the exact pocket computer to a new slot in my inventory using number keys without changing the state of the computer.
REPRODUCTION STEPS:
1. Hover your mouse over the pocket computer in your hotbar
2. press any number key to move it to a new slot
3. try to access the computer and see if anything changed. if nothing changed, turn off the computer and repeat from step 1

#6 oeed

    Oversimplifier

  • Members
  • 2,095 posts
  • LocationAuckland, New Zealand

Posted 22 March 2014 - 09:34 AM

VERSION:
1.6pr7
DESCRIPTION:
Shift right-clicking on a disc drive whilst holding a pocket computer does not insert the pocket computer into the drive.
EXPECTED RESULT:
When shift right-clicking on a disc drive whilst holding a pocket computer the pocket computer would be inserted in to the drive, as discs do.
REPRODUCTION STEPS:
Hold a pocket computer and shift right-click on a disc drive.

Edited by oeed, 22 March 2014 - 11:27 PM.


#7 Dog

  • Members
  • 1,161 posts
  • LocationEarth orbit

Posted 10 April 2014 - 06:11 PM

Version:
1.63 release (and 1.62, not sure about 1.6 or 1.61) CSP

Description:
Turtles (standard or advanced) seem to randomly get 'stuck' while selecting an inventory slot. Seems to happen most often at game start. I have several turtles that run the following code on startup - random ones stop at "turtle.select(i)" and must have the program terminated and restarted.
local function inventorySlots()
  local tmpSlot = turtle.getSelectedSlot()
  gtInventory = { }
  local i
  for i = 1,16,1 do
	turtle.select(i)
	selectedSlot = i
	gtInventory[i] = turtle.getItemCount(i)
  end
  turtle.select(tmpSlot)
  selectedSlot = turtle.getSelectedSlot()
  return true
end

Expected Results:
Turtles can select slots in inventory without 'freezing'

Reproduction Steps:
Have turtles automatically select (and count the items in) every slot on startup - happens randomly


Fixed in 1.64pr5

Edited by dan200, 18 September 2014 - 08:54 PM.


#8 Malte

  • Members
  • 13 posts

Posted 17 April 2014 - 11:37 PM

I'm not sure if it was already reported, but if it was, it still should be fixed. It's an pretty annoying bug for non-english users...

Version: Every version including 1.6.4 pre1
Description: The "edit" program acts weird when using special letters from languages like German. Such letters are ä, ö, ü, ß. Also á, é, è, ... are affected.
When the letter itself is written, it shows correctly. But if you type another letter behind it, they turn into differen ones and a questionmark is added. (See screenshot)
Also the cursor is shown at the wrong position. If you press the right arrow key after each special letter, you can continue typing without the letters getting messed up, but the cursor is shown one space too far to the left for each "special letter". See http://prntscr.com/3azw30

And another problem is, that some keys (like " { [ ] } \ ") requires to press the "Alt Gr" key on german keyboards. But if pressed, it just opens the menu, as if i would have pressed "Ctrl". That's pretty annoying...

Expected result: Normal behaviour with non-english keyboards with special letters

Reproduction steps: Set your keyboard layout to german. Then go into the edit software and press the following keys:
- ' - ' for 'ß'
- ' [ ' for 'ü'
- ' ; ' for 'ö'
- ' ' ' for 'ä'


Try to write words including the special letters and you will see it won't work properly.

Also to test the problem with the "Alt Gr" key:

- "Alt Gr + 7" for ' { '
- "Alt Gr + 8" for ' [ '
- "Alt Gr + 9" for ' ] '
- "Alt Gr + 0" for ' } '

Screenshot: http://puu.sh/8cVdN.png

Edited by Malte, 17 April 2014 - 11:38 PM.


#9 KryQ

  • New Members
  • 2 posts

Posted 08 May 2014 - 07:08 PM

VERSION:
CC: 1.64pr2
MC 1.7.2
FORGE 10.12.1.1060

MODS:
IC2Exp, ae2, bc5, voxel map, wireles redstone

DESCRIPTION:
Turtle fills recycler not using stacks from inventory. More in video
ADD: Also closes door as he passes trough.

https://www.youtube....h?v=W0Fo4YqXxPU


Fixed in 1.64pr5

Edited by dan200, 18 September 2014 - 05:52 PM.


#10 YoshiGenius

  • New Members
  • 1 posts

Posted 17 May 2014 - 03:15 AM

ComputerCraft version: pr2

Description:

Game crashes with this message. (NEI recipe searching)


java.lang.NullPointerException: Updating screen events
at dan200.computercraft.shared.turtle.items.TurtleItemFactory.create(TurtleItemFactory.java:50)
at dan200.computercraft.shared.turtle.recipes.TurtleRecipe.func_77571_b(TurtleRecipe.java:38)
at appeng.integration.modules.NEIHelpers.NEIAEShapedRecipeHandler.loadCraftingRecipes(NEIAEShapedRecipeHandler.java:73)
at codechicken.nei.recipe.TemplateRecipeHandler.loadCraftingRecipes(TemplateRecipeHandler.java:327)
at appeng.integration.modules.NEIHelpers.NEIAEShapedRecipeHandler.loadCraftingRecipes(NEIAEShapedRecipeHandler.java:64)
at codechicken.nei.recipe.TemplateRecipeHandler.getRecipeHandler(TemplateRecipeHandler.java:465)
at codechicken.nei.recipe.GuiCraftingRecipe.openRecipeGui(GuiCraftingRecipe.java:20)
at codechicken.nei.ItemPanel.mouseUp(ItemPanel.java:268)
at codechicken.nei.LayoutManager.onMouseUp(LayoutManager.java:167)
at codechicken.nei.guihook.GuiContainerManager.mouseUp(GuiContainerManager.java:378)
at codechicken.nei.guihook.GuiContainerManager.overrideMouseUp(GuiContainerManager.java:370)
at net.minecraft.client.gui.inventory.GuiContainer.func_146286_b(GuiContainer.java)
at net.minecraft.client.gui.GuiScreen.func_146274_d(GuiScreen.java:312)
at net.minecraft.client.gui.inventory.GuiContainer.func_146274_d(GuiContainer.java)
at net.minecraft.client.gui.GuiScreen.func_146269_k(GuiScreen.java:269)

Reproduction

Click on the item in NEI to attempt to see the recipe. I have AE2 installed as well, so it may have been that.

#11 Kokiri

  • New Members
  • 1 posts

Posted 30 May 2014 - 12:12 AM

[02:09:10] [Server thread/INFO] [FML/Forge]:   Unknown recipe class! dan200.computercraft.shared.media.recipes.DiskRecipe Modder please refer to net.minecraftforge.oredict.RecipeSorter
[02:09:10] [Server thread/INFO] [FML/Forge]:   Unknown recipe class! dan200.computercraft.shared.util.ImpostorShapelessRecipe Modder please refer to net.minecraftforge.oredict.RecipeSorter
[02:09:10] [Server thread/INFO] [FML/Forge]:   Unknown recipe class! dan200.computercraft.shared.media.recipes.PrintoutRecipe Modder please refer to net.minecraftforge.oredict.RecipeSorter
[02:09:10] [Server thread/INFO] [FML/Forge]:   Unknown recipe class! dan200.computercraft.shared.pocket.recipes.PocketComputerUpgradeRecipe Modder please refer to net.minecraftforge.oredict.RecipeSorter
[02:09:10] [Server thread/INFO] [FML/Forge]:   Unknown recipe class! dan200.computercraft.shared.util.ImpostorRecipe Modder please refer to net.minecraftforge.oredict.Recipe


Fixed in 1.64pr5

#12 gronkdamage

  • Members
  • 115 posts

Posted 05 June 2014 - 07:41 PM

Another issue - I have a program that is a small loop that says 'go up, place block' - and repeats. (code below for the place function) - On the fourth place block, it doesn't always place the cobble (in this case) directly in front of it like it should; it instead 'skips' and places the block 1 block away (ie. turtle in block 1, should place it in block 2, but instead places it in block 3).

function PlaceBlock()
	gotoNextSlotIfEmpty()
--	if not turtle.compare() then
		while not turtle.place() do
			turtle.attack()
			if turtle.detect() and not turtle.dig() then
				-- found obsidian
				return
			end
		end
--	end
end

the compare is commented out due to bug....

It's random - and I'm having troubles reproducing it effectively; but it is repeating itself on occasion (can't figure out why).

EDIT: I've been running the program multiple times to try and figure out the problem, and it just did something new (and buggy):


A B C
D E F
G H I

Turtle was in E; was given the command turtle.place() - and should have placed the block in D; it instead placed the block in G (at an angle). Using code above...


Fixed in 1.64pr5

Edited by dan200, 18 September 2014 - 09:43 PM.


#13 cavac

  • New Members
  • 1 posts

Posted 09 June 2014 - 10:57 AM

VERSION:
1.64pr2 + Archimedes Ships Mod 1.6.1
DESCRIPTION:
An active Computer crashes the game and corrupts the World when mounting an Archimedes Ships mod ship. Restoring only the chunks from Backup does not fix the problem.
EXPECTED RESULT:
Don't corrupting the world would be a good start. I think, automatically shutting down the computer or pausing execution while moving the ship would be ok.
REPRODUCTION STEPS:
Install MC 1.7.2, latest stable Forge, Archimedes Ships mod and CC 1.64pr2. Build a ship (Blocks of wood floating in water+add helm), Add Computer to ship and execute program. Compile and mount the ship.
SCREENSHOT/VIDEO:
https://www.youtube....h?v=Ij1cW3yS_LE


Mods like archimedes ships are notioriously unstable, we can't realistically support this. Also: you didnt post a crashlog

#14 JediKnyghte

  • Members
  • 9 posts

Posted 11 June 2014 - 02:58 AM

Version: 1.6pr3, MC 1.7.2

Description:
Erratic behavior in placeDown()--sometimes blocks just don't place, and sometimes a block is placed two blocks below a turtle instead of one.

Reproduction steps:
As I said, it's erratic. I messed around a bit in creative trying to get a simple case and couldn't. Here's what's happening:

In a standard random world, level out a row 64 blocks long (or whatever--the length isn't all that relevant) over an area with ups and downs in it (you don't want to start with a smooth surface). Then place 64 blocks of dirt in slot 1 and run this:

turtle.select(1)
for i = 1, 64 do
  turtle.placeDown()
  turtle.forward()
end

Most blocks will be placed correctly, but some blocks won't be placed at all, and some will be placed one lower level than they ought to be. I've observed this both in dirt at normal ground level and in placing blocks on a long section interspersed with bedrock at level 6.

It looks as if it gets confused moving from a position where there is a block beneath to when there isn't, but it doesn't happen all the time and, as I said, I couldn't come up with an artificial example in creative.

Ah--I see there are place() bugs listed already (I just looked for placeDown()). Grass does explain some of it, but neither grass nor water explains the level 6 problems I'm seeing. It's having problems over plain old empty blocks.


Fixed in 1.64pr5

#15 gronkdamage

  • Members
  • 115 posts

Posted 13 June 2014 - 08:59 AM

turtle.suck() or possibly turtle.drop() is technically broken and can be easily abused...

My code is simply:

while not(turtle.getItemCount(1) == 64) do
	turtle.suckUp()
end

After it gets the 64 count it's looking for, it goes through slots 2,16 and puts any excess back. But, it's putting back what it took - while adding to it's inventory.

In other words:

Say you have 50 blocks in slot 1 and you run this load/unload code - it does what it should: begins looping until it can suck in more... BUT, if you then put 64 blocks of cobble into the chest above it, it'll suck the 64 in - and put back 64 cobble... Checking slot 1; there is now 64 cobble. Magically, blocks of cobble have 'appeared' out of thin air... Not only a bug, but potentially an exploit.

I expected to put 64 in, and see 50 put back - not 64....


Fixed in 1.64pr5

#16 JediKnyghte

  • Members
  • 9 posts

Posted 19 June 2014 - 06:24 PM

Version: 1.6pr2, MC 1.7.2

Description: Running a minecart under a turtle while the turtle is placeDown()ing a rail crashes Minecraft.

Reproduction step: Set up railroad tracks with a powered rail. ==#==
Set up a turtle to run this:
turtle.select(1)
for i = 1, 16 do
  turtle.placeDown()
  turtle.forward()
end
Place the turtle just past the powered rail, one level up from the ground, load rails into slot 1, but don't start it.
Place a minecart on the other side of the rail, but don't bump it.
Start up the turtle, and shove the minecart onto the powered rail. It will zoom under the turtle and the game will freeze and then crash.

Crash log below.

I am willing to admit that this probably falls into the "don't do that" category except that I've done it twice by accident in the last day.

Spoiler


Fixed in 1.64pr5

#17 noobtube2

  • Members
  • 4 posts

Posted 25 June 2014 - 07:30 PM

VERSION:
1.6pre3
DESCRIPTION:
shift clicking turtle into invetory hotbar slot gives an occasional graphical bug where the tool on the turtle side would be on a dark greenish canvas.
(turtle used was an advanced mining turtle)
EXPECTED RESULT:
to not look like it has a giant pickaxe picture is strapped to the turtle.
REPRODUCTION STEPS:
shift click an advanced mining turtle into the hot bar.
Note it doesn't always happen.

Sorry if this is not clear i'm not great at explaining things but i did my best.


Fixed in 1.64pr5

#18 infiniteunrest

  • New Members
  • 1 posts

Posted 27 June 2014 - 06:05 PM

Version: 1.64pr3

Description:
Travelling using a Mystcraft linking book to a location that contains CC entities.

Reproduction:
Happens every time.

http://pastebin.com/pENU9dqb

#19 Razorskills

  • Members
  • 6 posts

Posted 29 June 2014 - 10:47 PM

Hey there, I am having an odd bug with ComputerCraft 1.6.3 for Minecraft 1.6.4

It is basically a crash that happens between ComputerCraft and Infernal Mobs by AtomicStryker

I sent him a message about it and here a link to the post and the actual word:
Forum Post

-------------------------------------------------------------------------------------------------------------------------------------------------------------------
Hey AtomicStryker!

I'm getting this crash consistently with 1.6.4,

https://www.dropbox....0.18-server.txt

(you can view it at that link without downloading the file, but can also download it too. I can also provide more info if needed)

Im just wondering if you could just have a peek at it and tell me if its a problem with your mod, or another. Im not asking you to fix it, I just want to know if its your mod that is doing this since it mentions yours. It also mentions computer craft and I will bring it to his attention aswell.

If it is your mod and you decide to push a fix cool, but no fix, it just means I can't use it anymore really..

---------------
Actually know now that I'm thinking about it/re-reading the crash, I think it is caused from a poisonous mob (that was given the attribute by Infernal Mobs) standing in front of a turtle and the turtle getting whatever the effect the mob is supposed to give a player.

I think if it could check if the thing that punched it is a player before giving the side effects of punching it, the crash would not occur again, or for any other mod.

This might even be just good to add in your 1.7 version since computer craft exists there too, and I bet you it will happen there too. I need to test it of course and if you want me to I can. Just let me know!
--------------------------------------------------------------------------------------------------------------------------
End Of Forum Post Copy


That there pretty much sums up the problem, the turtles seem to be crashing the game when they punch a mob that has an Infernal Property.
Example: a Poisonous property would make the player become poisoned if they touch the mob(punch)

And I am assuming from the crash: crash-2014-06-28_15.30.18-server.txt

That it attempted to poison the turtle..

So im just wondering if there might be a possible fix for this in 1.6? And if not, then il just have to take out Infernal mobs..

But It might also be a problem that exists in 1.7 if the code for it hasn't changed too drastically.

Edited by Razorskills, 29 June 2014 - 10:50 PM.


#20 gronkdamage

  • Members
  • 115 posts

Posted 30 June 2014 - 11:55 AM

Version 1.64pr3

turtle.place() is still buggy. I'm having turtles placing blocks 2 blocks in front of the turtle (it's a "leave pile" from Biomes O' Plenty in this case)


Fixed in 1.64pr5





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users