Jump to content




OneOS Version 2 - The All in One Operating System


910 replies to this topic

#561 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 26 August 2014 - 11:25 PM

View Postoeed, on 26 August 2014 - 10:29 PM, said:

View PostJiloacom, on 26 August 2014 - 10:28 PM, said:

I tried opening up the startup program with "Files", and it errored with this.

Bedrock.lua:385: No object type specified. (e.g. Type = "Button") Name: ?

The program has finished.
Click anywhere to close this program.

Well, uh, don't open the startup file :P I could probably add something to prevent it from opening it though.

I thought that was the only way you could set "IsDebug" to true and start modifying OneOS.

EDIT: Though you could probably add a setting for that, where if you set it to true, all of the Operating System files unlock, and "isDebug" sets to true. Otherwise, all the Operating System files would be locked.

Edited by Jiloacom, 26 August 2014 - 11:26 PM.


#562 oeed

    Oversimplifier

  • Members
  • 2,095 posts
  • LocationAuckland, New Zealand

Posted 27 August 2014 - 04:59 AM

View PostJiloacom, on 26 August 2014 - 11:25 PM, said:

I thought that was the only way you could set "IsDebug" to true and start modifying OneOS.

EDIT: Though you could probably add a setting for that, where if you set it to true, all of the Operating System files unlock, and "isDebug" sets to true. Otherwise, all the Operating System files would be locked.

Well, setting IsDebug is not really necessary anymore.

I was more thinking of preventing it from being executed. Editing it fine, but when you run it the sandbox doesn't work correctly so it can't find any of the files.

Edited by oeed, 27 August 2014 - 04:59 AM.


#563 tenshae

  • Members
  • 66 posts

Posted 27 August 2014 - 06:43 PM

You should make a custom bootloader for this, maybe even support for more than one OS.

#564 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 27 August 2014 - 07:11 PM

Hey, you should add the ability when making a new file, to select what kind of file you want to make and with what editor/IDE. For example, if I clicked "New File" in the documents folder, it would open up an option box where I could select the .ink or .txt file and use the program "Ink" to create it.

#565 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 27 August 2014 - 07:21 PM

Oh, by the way, when I try to write the \ character in sketch, OneOS freaks out and reboots.

#566 skwerlman

  • Members
  • 163 posts
  • LocationPennsylvania

Posted 29 August 2014 - 12:35 PM

View PostJiloacom, on 27 August 2014 - 07:21 PM, said:

Oh, by the way, when I try to write the \ character in sketch, OneOS freaks out and reboots.
That's a byproduct of setting isDebug to true, iirc.

#567 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 29 August 2014 - 07:41 PM

Whenever I try to open something using "Open with...", it crashes with this:

Bedrock.lua:385: No object type specified. (e.g. Type = "Button") Name: ?

The program has finished.
Click anywhere to close this program

And no, I'm not trying to open up a piece of the O.S., and yes, isDebug is set to false.

#568 oeed

    Oversimplifier

  • Members
  • 2,095 posts
  • LocationAuckland, New Zealand

Posted 29 August 2014 - 10:54 PM

View Postskwerlman, on 29 August 2014 - 12:35 PM, said:

View PostJiloacom, on 27 August 2014 - 07:21 PM, said:

Oh, by the way, when I try to write the \ character in sketch, OneOS freaks out and reboots.
That's a byproduct of setting isDebug to true, iirc.
Yes, that is correct.

View PostJiloacom, on 29 August 2014 - 07:41 PM, said:

Whenever I try to open something using "Open with...", it crashes with this:

Bedrock.lua:385: No object type specified. (e.g. Type = "Button") Name: ?

The program has finished.
Click anywhere to close this program

And no, I'm not trying to open up a piece of the O.S., and yes, isDebug is set to false.
Hmmmm, I'll take a look in to that.

#569 Gumball

  • Members
  • 254 posts
  • LocationFairbanks, Alaska

Posted 31 August 2014 - 03:52 AM

View PostRamiLego4Game, on 01 March 2014 - 12:07 PM, said:

You are Superior,Can you Add My Game (CCRedirection)?
Also The ccappstore.com page not working (DNS Error (dns_server_failure) )

You sure thats yours? :mellow: Cause I think dan200 made taht -_-

#570 MKlegoman357

  • Members
  • 1,170 posts
  • LocationKaunas, Lithuania

Posted 31 August 2014 - 06:48 PM

View Postbluebird173, on 31 August 2014 - 03:52 AM, said:

View PostRamiLego4Game, on 01 March 2014 - 12:07 PM, said:

You are Superior,Can you Add My Game (CCRedirection)?
Also The ccappstore.com page not working (DNS Error (dns_server_failure)

You sure thats yours? :mellow: Cause I think dan200 made taht -_-

Dan200 made the real Redirection game, RamiLego4Game made a CC edition of it. Dan200 just edited the CC edition a little.

#571 Scrumilation

  • New Members
  • 1 posts

Posted 31 August 2014 - 07:22 PM

How do i uninstall it?
It's annoying me more then helping, this is an awesome project and i can see how much work you put into it but it's just not working for me :

EDIT: Just noticed that giving a name to the computer gives it an alias, so replacing the computer was not restoring everything, i feel retarded now.

Edited by Scrumilation, 31 August 2014 - 07:25 PM.


#572 oeed

    Oversimplifier

  • Members
  • 2,095 posts
  • LocationAuckland, New Zealand

Posted 31 August 2014 - 10:17 PM

View PostScrumilation, on 31 August 2014 - 07:22 PM, said:

How do i uninstall it?
It's annoying me more then helping, this is an awesome project and i can see how much work you put into it but it's just not working for me :

EDIT: Just noticed that giving a name to the computer gives it an alias, so replacing the computer was not restoring everything, i feel retarded now.
To uninstall hold alt while booting and wipe the computer.

#573 Dweller_Benthos

  • Members
  • 14 posts

Posted 16 September 2014 - 04:07 PM

View Postoeed, on 17 August 2014 - 09:37 PM, said:

View PostTombot44, on 17 August 2014 - 02:15 PM, said:

Hi,
Finally got CC!
I found a bug, on my Adv. Monitor with my Adv. Computer I can not click.

I presume OneOS is showing on the monitor though? If it's not open the monitor in Files and click the button.

I'm seeing the same thing, OneOS is on the advanced monitor, but left-clicking, right-clicking, middle-clicking, shift-clicking etc does nothing. Works fine in the internal computer screen.

Though this may be an issue outside OneOS as I also have problems using an advanced monitor with other programs like the bonus "game of life" disk you find as loot. Right clicking works to turn a pixel on, but there's no way to turn it back off again. Not sure if that's related, but thought I'd mention it.

#574 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 16 September 2014 - 04:30 PM

Oh my! OneOS is the third most viewed operating system on this forum! (With PearOS trailing by just a few hundred) :lol:

#575 oeed

    Oversimplifier

  • Members
  • 2,095 posts
  • LocationAuckland, New Zealand

Posted 16 September 2014 - 09:51 PM

View PostDweller_Benthos, on 16 September 2014 - 04:07 PM, said:

I'm seeing the same thing, OneOS is on the advanced monitor, but left-clicking, right-clicking, middle-clicking, shift-clicking etc does nothing. Works fine in the internal computer screen.

Though this may be an issue outside OneOS as I also have problems using an advanced monitor with other programs like the bonus "game of life" disk you find as loot. Right clicking works to turn a pixel on, but there's no way to turn it back off again. Not sure if that's related, but thought I'd mention it.

I'll take a look at those issues, you can only left click on monitors though. Are you running GoL inside OneOS?

View PostJiloacom, on 16 September 2014 - 04:30 PM, said:

Oh my! OneOS is the third most viewed operating system on this forum! (With PearOS trailing by just a few hundred) :lol:

It is also the single most replied to program, 574, followed by Advanced Mining Turtle with 573 :D

Edited by oeed, 16 September 2014 - 09:52 PM.


#576 Dweller_Benthos

  • Members
  • 14 posts

Posted 17 September 2014 - 06:17 PM

View Postoeed, on 16 September 2014 - 09:51 PM, said:

View PostDweller_Benthos, on 16 September 2014 - 04:07 PM, said:

I'm seeing the same thing, OneOS is on the advanced monitor, but left-clicking, right-clicking, middle-clicking, shift-clicking etc does nothing. Works fine in the internal computer screen.

Though this may be an issue outside OneOS as I also have problems using an advanced monitor with other programs like the bonus "game of life" disk you find as loot. Right clicking works to turn a pixel on, but there's no way to turn it back off again. Not sure if that's related, but thought I'd mention it.

I'll take a look at those issues, you can only left click on monitors though. Are you running GoL inside OneOS?


Left clicking a monitor does nothing for me, only right clicking, at least in game of life. I was running that under regular computer craft OS, not OneOS. But no amount of clicking of any type on a monitor in OneOS does anything.

#577 darkdata

  • New Members
  • 2 posts

Posted 20 September 2014 - 09:36 PM

will not install. the error i get in the screen shot

Posted Image

Edited by darkdata, 21 September 2014 - 01:01 AM.


#578 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 20 September 2014 - 10:23 PM

View Postdarkdata, on 20 September 2014 - 09:36 PM, said:

will not install. the error i get in the screen shot

Posted Image

Fixed URL.

http://fsflive.com/cc164

#579 darkdata

  • New Members
  • 2 posts

Posted 21 September 2014 - 01:02 AM

View PostJiloacom, on 20 September 2014 - 10:23 PM, said:

View Postdarkdata, on 20 September 2014 - 09:36 PM, said:

will not install. the error i get in the screen shot

Posted Image

Fixed URL.

http://fsflive.com/cc164

Posted Image

#580 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 24 September 2014 - 03:59 PM

Bug: When I try to select a file using "Open With..." it errors OneOS/Bedrock with this:

Bedrock.lua:385: No object type specified. (e.g. Type = "Button") Name: ?

The program has finished.
Click anywhere to close this program.

But OneOS itself has crashed, and it will no longer respond to anything, so I have to restart the computer and let OneOS reboot.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users