Jump to content




Bee Breeding with OpenPeripherals (now with Bee Matron)


321 replies to this topic

#41 NerdimusPrime

  • Members
  • 21 posts

Posted 29 March 2014 - 06:25 PM

View PostMcLeopold, on 29 March 2014 - 07:11 AM, said:

View PostNerdimusPrime, on 29 March 2014 - 03:46 AM, said:

Oops, ran into another error. "openbee:590: attempt to compare nil with number"
Fixed.

Looks like it's working great now. I started an imperial run when I got up this morning and I'm up to noble now. I wanted to upgrade to CC 1.6 but now that the breeder is working I'm almost afraid to. lol

#42 Technium

  • Members
  • 6 posts

Posted 29 March 2014 - 06:52 PM

Right, had some good progress over night on 4 breeders but I've run into:

openbee:126: attempt to index ? (a nil value)

This looks like it's because it hit "Leporine"... an easter special I think?

#43 McLeopold

  • Members
  • 123 posts

Posted 29 March 2014 - 10:50 PM

View PostNerdimusPrime, on 29 March 2014 - 06:25 PM, said:

Looks like it's working great now. I started an imperial run when I got up this morning and I'm up to noble now. I wanted to upgrade to CC 1.6 but now that the breeder is working I'm almost afraid to. lol

OpenPeripherals isn't ready for CC 1.6 yet. At least the narcissistic turtle weren't available when I tried.

View PostTechnium, on 29 March 2014 - 06:52 PM, said:

This looks like it's because it hit "Leporine"... an easter special I think?

I got those bees too. Just pull them out for now. I'm not sure how I want to handle unknown bees yet.

#44 VerTiGo_Etrex

  • Members
  • 11 posts

Posted 30 March 2014 - 12:08 AM

They're not really "unknown", right? They just don't mutate into anything, because their the most mutated bee of their species. Just make them purebred?

#45 NerdimusPrime

  • Members
  • 21 posts

Posted 30 March 2014 - 12:14 AM

View PostMcLeopold, on 29 March 2014 - 10:50 PM, said:


OpenPeripherals isn't ready for CC 1.6 yet. At least the narcissistic turtle weren't available when I tried.

Yeah, we tried it just to see, and quickly reverted back.

#46 McLeopold

  • Members
  • 123 posts

Posted 30 March 2014 - 01:02 AM

View PostVerTiGo_Etrex, on 30 March 2014 - 12:08 AM, said:

They're not really "unknown", right? They just don't mutate into anything, because their the most mutated bee of their species. Just make them purebred?

Unknown, as in getBeeBreedingData doesn't return them as a mutation. I'd have to hardcode it in.

#47 VerTiGo_Etrex

  • Members
  • 11 posts

Posted 30 March 2014 - 03:32 AM

Alternatively, you could assume that bees with no mutations can only mutate into themselves? i.e if the mutations table is nil, just make a fake entry for that bee and a drone of the same type, or one mutation below it. Maybe I don't fully understand how bee breeding works?

#48 NerdimusPrime

  • Members
  • 21 posts

Posted 30 March 2014 - 07:31 PM

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5

#49 MrEmielH

  • Members
  • 70 posts

Posted 30 March 2014 - 08:23 PM

View PostNerdimusPrime, on 30 March 2014 - 07:31 PM, said:

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5
that is probably the leporine thing, i got it too today

#50 McLeopold

  • Members
  • 123 posts

Posted 30 March 2014 - 10:13 PM

View PostMrEmielH, on 30 March 2014 - 08:23 PM, said:

View PostNerdimusPrime, on 30 March 2014 - 07:31 PM, said:

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5
that is probably the leporine thing, i got it too today
Just pushed a fix for this. I'm assuming these bees have a zero percent chance of mutation. They will be less likely to be picked for any target species, which might be good if they are special.

#51 NerdimusPrime

  • Members
  • 21 posts

Posted 30 March 2014 - 10:25 PM

View PostMcLeopold, on 30 March 2014 - 10:13 PM, said:

View PostMrEmielH, on 30 March 2014 - 08:23 PM, said:

View PostNerdimusPrime, on 30 March 2014 - 07:31 PM, said:

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5
that is probably the leporine thing, i got it too today
Just pushed a fix for this. I'm assuming these bees have a zero percent chance of mutation. They will be less likely to be picked for any target species, which might be good if they are special.

Cool, thanks. I'll give it a try right now.

#52 VerTiGo_Etrex

  • Members
  • 11 posts

Posted 31 March 2014 - 02:23 AM

View PostMcLeopold, on 30 March 2014 - 10:13 PM, said:

View PostMrEmielH, on 30 March 2014 - 08:23 PM, said:

View PostNerdimusPrime, on 30 March 2014 - 07:31 PM, said:

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5
that is probably the leporine thing, i got it too today
Just pushed a fix for this. I'm assuming these bees have a zero percent chance of mutation. They will be less likely to be picked for any target species, which might be good if they are special.

Thy don't have 0 chance of mutation though, do they? If they're a hybrid, then they can mutate into a purebred.

#53 apemanzilla

  • Members
  • 1,421 posts

Posted 31 March 2014 - 01:02 PM

View PostVerTiGo_Etrex, on 31 March 2014 - 02:23 AM, said:

View PostMcLeopold, on 30 March 2014 - 10:13 PM, said:

View PostMrEmielH, on 30 March 2014 - 08:23 PM, said:

View PostNerdimusPrime, on 30 March 2014 - 07:31 PM, said:

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5
that is probably the leporine thing, i got it too today
Just pushed a fix for this. I'm assuming these bees have a zero percent chance of mutation. They will be less likely to be picked for any target species, which might be good if they are special.

Thy don't have 0 chance of mutation though, do they? If they're a hybrid, then they can mutate into a purebred.
Hybrid to purebred isn't always a mutation. Many times it's just spreading the trait to produce a purebred; not actually mutating.

#54 McLeopold

  • Members
  • 123 posts

Posted 31 March 2014 - 05:39 PM

View PostApemanzilla, on 31 March 2014 - 01:02 PM, said:

View PostVerTiGo_Etrex, on 31 March 2014 - 02:23 AM, said:

View PostMcLeopold, on 30 March 2014 - 10:13 PM, said:

View PostMrEmielH, on 30 March 2014 - 08:23 PM, said:

View PostNerdimusPrime, on 30 March 2014 - 07:31 PM, said:

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5
that is probably the leporine thing, i got it too today
Just pushed a fix for this. I'm assuming these bees have a zero percent chance of mutation. They will be less likely to be picked for any target species, which might be good if they are special.

Thy don't have 0 chance of mutation though, do they? If they're a hybrid, then they can mutate into a purebred.
Hybrid to purebred isn't always a mutation. Many times it's just spreading the trait to produce a purebred; not actually mutating.

My 0 percent chance isn't the actual game mechanic chance. I'm just going to return 0 if one of the 2 species is unknown or if the target species is unknown. This should reduce the species score enough that these bees don't get picked.

#55 NerdimusPrime

  • Members
  • 21 posts

Posted 31 March 2014 - 05:52 PM

View PostNerdimusPrime, on 30 March 2014 - 10:25 PM, said:

View PostMcLeopold, on 30 March 2014 - 10:13 PM, said:

View PostMrEmielH, on 30 March 2014 - 08:23 PM, said:

View PostNerdimusPrime, on 30 March 2014 - 07:31 PM, said:

Everything has been running pretty smoothly until today when I was making another industrious princess. I've made three of them before and not had a problem, but I just got this partway through the process: http://imgur.com/ig69ur5
that is probably the leporine thing, i got it too today
Just pushed a fix for this. I'm assuming these bees have a zero percent chance of mutation. They will be less likely to be picked for any target species, which might be good if they are special.

Cool, thanks. I'll give it a try right now.

That fix seems to have done the trick; I haven't had an error since, so thanks!

I did get one instance of odd behavior, but it didn't generate any errors, and I was able to bypass it. It was breeding down some advanced species to make reference bees with better traits, before breeding them back up to industrious. At one point it seemed to be stuck in a loop of breeding the same meadows princess and drones over and over again. It went through multiple cycles of this before I noticed what was happening. By then the princess and drones had the exact same traits in every way, as far as I could determine, but it kept re-breeding them anyway.

When I took them out, it grabbed an improved forest princess instead, and continued breeding up to industrious as it should have. I bred one more industrious after that, but the behavior didn't repeat. I only mention it because it was interesting.

#56 MrEmielH

  • Members
  • 70 posts

Posted 31 March 2014 - 06:53 PM

are there plans to be able to use the indexer instead of a chest?

#57 McLeopold

  • Members
  • 123 posts

Posted 31 March 2014 - 06:57 PM

View PostMrEmielH, on 31 March 2014 - 06:53 PM, said:

are there plans to be able to use the indexer instead of a chest?

Yes, after I get the product chest going. You can't push product to an apiary chest or indexer, so right now it's not going to work. Go ahead and put it on top to see what the behavior is. I'm think combs would just stay in the apiary and slow down the clearApiary function.

#58 MrEmielH

  • Members
  • 70 posts

Posted 31 March 2014 - 07:03 PM

View PostMcLeopold, on 31 March 2014 - 06:57 PM, said:

View PostMrEmielH, on 31 March 2014 - 06:53 PM, said:

are there plans to be able to use the indexer instead of a chest?

Yes, after I get the product chest going. You can't push product to an apiary chest or indexer, so right now it's not going to work. Go ahead and put it on top to see what the behavior is. I'm think combs would just stay in the apiary and slow down the clearApiary function.
ok thanks for the quick answer :)

#59 Crimor

  • Members
  • 3 posts

Posted 31 March 2014 - 07:16 PM

I gave it pure common and pure cultivated and set it to create imperial then went away for a few hours to do other stuff, it looks like it's just been breeding cultivated with cultivated the entire time, gave it 4 cultivated and 4 common princesses.

#60 NerdimusPrime

  • Members
  • 21 posts

Posted 31 March 2014 - 10:13 PM

View PostCrimor, on 31 March 2014 - 07:16 PM, said:

I gave it pure common and pure cultivated and set it to create imperial then went away for a few hours to do other stuff, it looks like it's just been breeding cultivated with cultivated the entire time, gave it 4 cultivated and 4 common princesses.

So I'm not the only one that's happened to.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users