Jump to content




[Off-Development]PockyOS v2.21 - Even more advanced pocket OS

computer utility api

150 replies to this topic

Poll: v2.2 poll (44 member(s) have cast votes)

Do ou like the update?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.

Is the current version buggy?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.

Should custom repos be my biggest priority for the next version?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.
Vote Guests cannot vote

#81 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 27 May 2014 - 06:38 PM

probably the last patch of 2.1 came out! 2.14 fixes the bugs listed in Konlab's post

#82 Konlab

  • Members
  • 595 posts
  • LocationKerbin

Posted 28 May 2014 - 10:36 AM

some installer things, that need changes:
in the upper right corner is written still 'v2.13', but only in installer
and if you install pockyOS:
'the installer hEs been...'

and the bugs :(
bug#1: the changing background don't working: main:1082:attempt to call nil
bug#2: if you try to read/edit a note: down appears: hi and No such program
bug#3: the 'add custom repo' and the 'remove custom repo' does nothing

#83 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 29 May 2014 - 03:36 AM

 Konlab, on 28 May 2014 - 10:36 AM, said:

some installer things, that need changes:
in the upper right corner is written still 'v2.13', but only in installer
and if you install pockyOS:
'the installer hEs been...'

and the bugs :(
bug#1: the changing background don't working: main:1082:attempt to call nil
bug#2: if you try to read/edit a note: down appears: hi and No such program
bug#3: the 'add custom repo' and the 'remove custom repo' does nothing
Patched the bugs.... again... but bug#1 isn't happening to me, did you update? Or using something such as emulator?

#84 Win7yes

  • Members
  • 110 posts

Posted 29 May 2014 - 05:04 AM

Random Question: If I ran this on a normal advanced computer, what happends?

EDIT: Well, I found out myself

First: all buttons will have to be clicked one pixel below from their original possition
Second: idk
Third: Potatoes

Edited by Win7yes, 29 May 2014 - 05:29 AM.


#85 Konlab

  • Members
  • 595 posts
  • LocationKerbin

Posted 29 May 2014 - 09:12 AM

 thediamondgames, on 29 May 2014 - 03:36 AM, said:

 Konlab, on 28 May 2014 - 10:36 AM, said:

some installer things, that need changes:
in the upper right corner is written still 'v2.13', but only in installer
and if you install pockyOS:
'the installer hEs been...'

and the bugs :(/>
bug#1: the changing background don't working: main:1082:attempt to call nil
bug#2: if you try to read/edit a note: down appears: hi and No such program
bug#3: the 'add custom repo' and the 'remove custom repo' does nothing
Patched the bugs.... again... but bug#1 isn't happening to me, did you update? Or using something such as emulator?
I tried in minecraft. Java latest.Minecraft 1.6.4,Computercraft 1.63.

#86 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 30 May 2014 - 03:22 AM

 Konlab, on 29 May 2014 - 09:12 AM, said:

 thediamondgames, on 29 May 2014 - 03:36 AM, said:

 Konlab, on 28 May 2014 - 10:36 AM, said:

some installer things, that need changes:
in the upper right corner is written still 'v2.13', but only in installer
and if you install pockyOS:
'the installer hEs been...'

and the bugs :(/>
bug#1: the changing background don't working: main:1082:attempt to call nil
bug#2: if you try to read/edit a note: down appears: hi and No such program
bug#3: the 'add custom repo' and the 'remove custom repo' does nothing
Patched the bugs.... again... but bug#1 isn't happening to me, did you update? Or using something such as emulator?
I tried in minecraft. Java latest.Minecraft 1.6.4,Computercraft 1.63.
I also use this! Tried on SP and MC+ (Bukkit + Forge) server

#87 Konlab

  • Members
  • 595 posts
  • LocationKerbin

Posted 30 May 2014 - 03:36 PM

 thediamondgames, on 30 May 2014 - 03:22 AM, said:

 Konlab, on 29 May 2014 - 09:12 AM, said:

 thediamondgames, on 29 May 2014 - 03:36 AM, said:

 Konlab, on 28 May 2014 - 10:36 AM, said:

some installer things, that need changes:
in the upper right corner is written still 'v2.13', but only in installer
and if you install pockyOS:
'the installer hEs been...'

and the bugs :(/>
bug#1: the changing background don't working: main:1082:attempt to call nil
bug#2: if you try to read/edit a note: down appears: hi and No such program
bug#3: the 'add custom repo' and the 'remove custom repo' does nothing
Patched the bugs.... again... but bug#1 isn't happening to me, did you update? Or using something such as emulator?
I tried in minecraft. Java latest.Minecraft 1.6.4,Computercraft 1.63.
I also use this! Tried on SP and MC+ (Bukkit + Forge) server

I in singleplayer

#88 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 30 May 2014 - 06:29 PM

 Konlab, on 30 May 2014 - 03:36 PM, said:

 thediamondgames, on 30 May 2014 - 03:22 AM, said:

 Konlab, on 29 May 2014 - 09:12 AM, said:

 thediamondgames, on 29 May 2014 - 03:36 AM, said:

 Konlab, on 28 May 2014 - 10:36 AM, said:

some installer things, that need changes:
in the upper right corner is written still 'v2.13', but only in installer
and if you install pockyOS:
'the installer hEs been...'

and the bugs :(/>
bug#1: the changing background don't working: main:1082:attempt to call nil
bug#2: if you try to read/edit a note: down appears: hi and No such program
bug#3: the 'add custom repo' and the 'remove custom repo' does nothing
Patched the bugs.... again... but bug#1 isn't happening to me, did you update? Or using something such as emulator?
I tried in minecraft. Java latest.Minecraft 1.6.4,Computercraft 1.63.
I also use this! Tried on SP and MC+ (Bukkit + Forge) server

I in singleplayer
There's a small chance: because of diferent forge version it may glitch

#89 apemanzilla

  • Members
  • 1,421 posts

Posted 30 May 2014 - 06:50 PM

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.

#90 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 02 June 2014 - 05:06 PM

 apemanzilla, on 30 May 2014 - 06:50 PM, said:

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.
I don't blame, that's not my mistake, feel free to check the code, while downloaded files it's placed at /pockyOS/main, in the line 1082 it's clearly written that it calls a function which was already defined above that code.

#91 apemanzilla

  • Members
  • 1,421 posts

Posted 02 June 2014 - 05:58 PM

 thediamondgames, on 02 June 2014 - 05:06 PM, said:

 apemanzilla, on 30 May 2014 - 06:50 PM, said:

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.
I don't blame, that's not my mistake, feel free to check the code, while downloaded files it's placed at /pockyOS/main, in the line 1082 it's clearly written that it calls a function which was already defined above that code.
Check that it wasn't overwritten or changed.

#92 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 02 June 2014 - 06:54 PM

 apemanzilla, on 02 June 2014 - 05:58 PM, said:

 thediamondgames, on 02 June 2014 - 05:06 PM, said:

 apemanzilla, on 30 May 2014 - 06:50 PM, said:

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.
I don't blame, that's not my mistake, feel free to check the code, while downloaded files it's placed at /pockyOS/main, in the line 1082 it's clearly written that it calls a function which was already defined above that code.
Check that it wasn't overwritten or changed.
Konlab maybe didn't update the OS, because after putting into webserver the version folder I don't change that folder.

#93 apemanzilla

  • Members
  • 1,421 posts

Posted 03 June 2014 - 04:04 PM

 thediamondgames, on 02 June 2014 - 06:54 PM, said:

 apemanzilla, on 02 June 2014 - 05:58 PM, said:

 thediamondgames, on 02 June 2014 - 05:06 PM, said:

 apemanzilla, on 30 May 2014 - 06:50 PM, said:

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.
I don't blame, that's not my mistake, feel free to check the code, while downloaded files it's placed at /pockyOS/main, in the line 1082 it's clearly written that it calls a function which was already defined above that code.
Check that it wasn't overwritten or changed.
Konlab maybe didn't update the OS, because after putting into webserver the version folder I don't change that folder.
I meant the function. Not the OS.

#94 Konlab

  • Members
  • 595 posts
  • LocationKerbin

Posted 03 June 2014 - 04:17 PM

 apemanzilla, on 03 June 2014 - 04:04 PM, said:

 thediamondgames, on 02 June 2014 - 06:54 PM, said:

 apemanzilla, on 02 June 2014 - 05:58 PM, said:

 thediamondgames, on 02 June 2014 - 05:06 PM, said:

 apemanzilla, on 30 May 2014 - 06:50 PM, said:

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.
I don't blame, that's not my mistake, feel free to check the code, while downloaded files it's placed at /pockyOS/main, in the line 1082 it's clearly written that it calls a function which was already defined above that code.
Check that it wasn't overwritten or changed.
Konlab maybe didn't update the OS, because after putting into webserver the version folder I don't change that folder.
I meant the function. Not the OS.

I used OS updater.
(My forge is latest.)
And this bug was the same in 2.1 ,2.1.1, 2.1.2 etc.
Please tell me where is that function defined?

#95 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 04 June 2014 - 01:42 PM

 Konlab, on 03 June 2014 - 04:17 PM, said:

 apemanzilla, on 03 June 2014 - 04:04 PM, said:

 thediamondgames, on 02 June 2014 - 06:54 PM, said:

 apemanzilla, on 02 June 2014 - 05:58 PM, said:

 thediamondgames, on 02 June 2014 - 05:06 PM, said:

 apemanzilla, on 30 May 2014 - 06:50 PM, said:

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.
I don't blame, that's not my mistake, feel free to check the code, while downloaded files it's placed at /pockyOS/main, in the line 1082 it's clearly written that it calls a function which was already defined above that code.
Check that it wasn't overwritten or changed.
Konlab maybe didn't update the OS, because after putting into webserver the version folder I don't change that folder.
I meant the function. Not the OS.

I used OS updater.
(My forge is latest.)
And this bug was the same in 2.1 ,2.1.1, 2.1.2 etc.
Please tell me where is that function defined?
Clicks function(what includes line 1082) is in 964
Err function(what is called in line 1082) is in line 87, it calls: exitit and rerun which are above the err function

#96 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 04 June 2014 - 02:54 PM

 apemanzilla, on 03 June 2014 - 04:04 PM, said:

 thediamondgames, on 02 June 2014 - 06:54 PM, said:

 apemanzilla, on 02 June 2014 - 05:58 PM, said:

 thediamondgames, on 02 June 2014 - 05:06 PM, said:

 apemanzilla, on 30 May 2014 - 06:50 PM, said:

Different forge versions would have basically no effect with versions that are compatible with CC. Don't blame Forge for your mistakes.
I don't blame, that's not my mistake, feel free to check the code, while downloaded files it's placed at /pockyOS/main, in the line 1082 it's clearly written that it calls a function which was already defined above that code.
Check that it wasn't overwritten or changed.
Konlab maybe didn't update the OS, because after putting into webserver the version folder I don't change that folder.
I meant the function. Not the OS.
Also I didn't change the function. The bugfixing was about change what to load in different parts of code, also does it happen to you?

#97 apemanzilla

  • Members
  • 1,421 posts

Posted 04 June 2014 - 06:14 PM

I didn't mean you changed the function yourself. If you accidentally missed a local and made a new global with the same name, or something along those lines, it might error.

I don't use any CC OS, except occasionally to provide feedback or testing.

#98 Konlab

  • Members
  • 595 posts
  • LocationKerbin

Posted 04 June 2014 - 06:26 PM

err() function?
That is the problem: my games uses err as variable.
My games uses ok,err = pcall(main) and the 'err' changes, and than that isn't a function but a string.

#99 GreenByteSoftware

  • Members
  • 135 posts
  • LocationKaunas, Lithuania

Posted 04 June 2014 - 06:54 PM

 Konlab, on 04 June 2014 - 06:26 PM, said:

err() function?
That is the problem: my games uses err as variable.
My games uses ok,err = pcall(main) and the 'err' changes, and than that isn't a function but a string.
oh! That's the problem! I know an idea - to make my function local if it's local so it won't conflict to your program.
Also try to make your programs with local functions too!
Edit:
Also to prevent this I will add to every function "pocky", with gedit it's going to be easy

Edited by thediamondgames, 04 June 2014 - 06:56 PM.


#100 Konlab

  • Members
  • 595 posts
  • LocationKerbin

Posted 04 June 2014 - 06:58 PM

Ok, now I know what is real(in prax) difference in global and local :(

I never used local variables, always i used globals.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users