Jump to content




Glass OS 5 : Discontinued :(

computer

78 replies to this topic

Poll: GLASS (63 member(s) have cast votes)

Which feature would be the best?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.

Do you like the NEW version?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.

Which rating will you give?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.

Should I discontinue GLASS os?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.
Vote Guests cannot vote

#21 viluon

  • Members
  • 183 posts
  • LocationCzech Republic

Posted 04 May 2014 - 11:50 AM

Command line interface

#22 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 11:54 AM

Can someone please do a review on something other than the installer and login?. :)

Edited by Glass Systems, 04 May 2014 - 11:54 AM.


#23 viluon

  • Members
  • 183 posts
  • LocationCzech Republic

Posted 04 May 2014 - 12:00 PM

I did

#24 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 12:03 PM

View Postviluon, on 04 May 2014 - 12:00 PM, said:

I did
How did you test the home screen? there was no startup :P It would error.

EDIT: who voted "good"?

Edited by Glass Systems, 04 May 2014 - 12:07 PM.


#25 viluon

  • Members
  • 183 posts
  • LocationCzech Republic

Posted 04 May 2014 - 12:09 PM

Me :D and btw I haven't tested your code. I'm reading it (yes, I can find bugs without debugging ;) )

Edit: and can't test now, I'm on Android
Edit2: polls are anonymous for a reason

Edited by viluon, 04 May 2014 - 12:11 PM.


#26 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 12:13 PM

View Postviluon, on 04 May 2014 - 12:09 PM, said:

Me :D and btw I haven't tested your code. I'm reading it (yes, I can find bugs without debugging ;) )

Edit: and can't test now, I'm on Android
Edit2: polls are anonymous for a reason
Thanks :) hope that you can test it soon :)

#27 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 12:22 PM

has anybody used the main screen? How to download an app: click on the "g" of glass press the "!" of download.
You will now be in the pastebin installer app, follow these steps:
1.enter slot
2.enter id
3.enter program name
4.paint icon


you can have a maximum of 6 programs.

To run your program click on the ">" next to it's name.

I'm going to make an instruction manual soon but i might discontinue this. :(

I'm pretty sure that the people who voted "noobish/decreases functionality" haven't even downloaded an app and seen the pretty animation.

to change the color click on "g" then click on "s"

Edited by Glass Systems, 04 May 2014 - 01:08 PM.


#28 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 04 May 2014 - 01:34 PM

Well, I create my account and get the OS installed. I login (with the right credentials) and it errors with "no such program".

#29 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 01:36 PM

did you run .system/settings.sys?
EDIT: Going for a walk for about half an hour.
EDIT2: read the instruction manual in the OP whilst I'm gone.

Edited by Glass Systems, 04 May 2014 - 01:40 PM.


#30 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 04 May 2014 - 01:49 PM

View PostGlass Systems, on 04 May 2014 - 01:36 PM, said:

did you run .system/settings.sys?
EDIT: Going for a walk for about half an hour.
EDIT2: read the instruction manual in the OP whilst I'm gone.

I'm sorry, but your Operating System should not be so complicated that you need a manual for it.

#31 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 04:11 PM

View PostJiloacom, on 04 May 2014 - 01:49 PM, said:

View PostGlass Systems, on 04 May 2014 - 01:36 PM, said:

did you run .system/settings.sys?
EDIT: Going for a walk for about half an hour.
EDIT2: read the instruction manual in the OP whilst I'm gone.

I'm sorry, but your Operating System should not be so complicated that you need a manual for it.
I'm sorry,but this is in early BETA in the full version it will have a tutorial and will be alot more easier to use.

Edited by Glass Systems, 04 May 2014 - 04:14 PM.


#32 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 04:21 PM

View PostGlass Systems, on 04 May 2014 - 04:11 PM, said:

View PostJiloacom, on 04 May 2014 - 01:49 PM, said:

View PostGlass Systems, on 04 May 2014 - 01:36 PM, said:

did you run .system/settings.sys?
EDIT: Going for a walk for about half an hour.
EDIT2: read the instruction manual in the OP whilst I'm gone.

I'm sorry, but your Operating System should not be so complicated that you need a manual for it.
I'm sorry,but this is in early BETA in the full version it will have a tutorial and will be alot more easier to use.
Before people use the poll:
1.If it's a bug,report it.
2.If there is something you want, suggest it.
3.remember this is EARLY BETA
4.If you haven't used the home screen, throw your computer away

#33 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 05:32 PM

adding update that will make .system/apps.sys easy-to-use

#34 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 04 May 2014 - 06:12 PM

The new update will include:
+Better design on the system apps and login
+easy-to-use
+better animation when launching apps
+using http.get for the installer
What do you think about these changes?Do you want more?
Post a reply below
note: Encryption will come later

Edited by Glass Systems, 04 May 2014 - 06:14 PM.


#35 Lyqyd

    Lua Liquidator

  • Moderators
  • 8,451 posts

Posted 04 May 2014 - 06:53 PM

View Postviluon, on 04 May 2014 - 10:00 AM, said:

View Postoeed, on 04 May 2014 - 09:09 AM, said:

View Postviluon, on 04 May 2014 - 09:05 AM, said:

(Haven't tested)
Arguments of a script run via shell.run(...) should be passed this way:
shell.run("cd","My Directory")
not this way:
shell.run("cd My Directory")

Both ways are completely valid. The second way is a bit newer (not 100% sure when it was added, probs 1.5), but if you're wanting compatibility with old version (again, not sure when it was added) then you'd be better with the first.
The second one is not. Try creating a script with name "cd My Directory"

Did you try it? Those two commands are 100% exactly the same, and will have the same results. Please review the way the shell parses shell.run's arguments before you go off disseminating bad information. For reference, any of the following will actually do what you're trying to do with the space in the argument, and all of these are identical:

shell.run("cd 'My Directory'")
shell.run("cd", "'My Directory'")
shell.run("cd 'My", "Directory'")
shell.run("cd", "'My", "Directory'")

Personally, I prefer the top one, as it seems to me to be the most sensible and easiest to read at a glance.

#36 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 05 May 2014 - 04:27 PM

Update released!

#37 viluon

  • Members
  • 183 posts
  • LocationCzech Republic

Posted 05 May 2014 - 05:09 PM

Lyqyd, you are using '' symbols to pass the argument, he was not. And yes, I tried.

Edit: ofc they're the same, but you use "'"

Edited by viluon, 05 May 2014 - 05:10 PM.


#38 realgogogoluke

  • Members
  • 79 posts
  • LocationContentia

Posted 06 May 2014 - 10:08 PM

When I picked cyan as the first choice, and light blue at the second choice, this error came up.Posted Image

#39 Blue

  • Members
  • 309 posts
  • LocationGlass/UX/main.lua

Posted 07 May 2014 - 05:27 AM

View Postrealgogogoluke, on 06 May 2014 - 10:08 PM, said:

When I picked cyan as the first choice, and light blue at the second choice, this error came up.Posted Image
Try typing lightBlue instead of light blue (hold ctrl+t and type in ".system/settings.sys")

Edited by Glass Systems, 07 May 2014 - 05:38 AM.


#40 Saldor010

  • Members
  • 467 posts
  • LocationThe United States

Posted 07 May 2014 - 01:40 PM

View PostGlass Systems, on 07 May 2014 - 05:27 AM, said:

View Postrealgogogoluke, on 06 May 2014 - 10:08 PM, said:

When I picked cyan as the first choice, and light blue at the second choice, this error came up.Posted Image
Try typing lightBlue instead of light blue (hold ctrl+t and type in ".system/settings.sys")

Couldn't you add "proper" error checking for this? Or better yet, make it button based or something so you won't have this problem?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users