Jump to content




MFR Autospawner Setup

turtle peripheral wireless

3 replies to this topic

#1 Obsidia

  • Members
  • 36 posts

Posted 12 August 2015 - 04:15 AM

Greetings,

Im currently searching for a program to use with MFR Autospawners. As Im not good enough yet and my tests to write one on my own failed, I gave up and searched for a program on pastebin.
The one I found and liked the most to this point was this here:

Imgur: http://imgur.com/a/e5M49
Reddit: https://www.reddit.c..._mob_additions/
Computer: http://pastebin.com/RUVP3cmJ
Turtle: http://pastebin.com/GaZ2uwUN

I never used the wireless stuff and I dont know how to get into it the easiest way. So i dont even understand how it works. Lol.
But I tried to use that code in a singleplayer world and I didnt managed to get it working.

I used: a advanced computer with 24 Monitors on the left and a Wireless modem on top.
a wireless turtle with the spawner on top and a chest below it.

I always get the error codes: computer: "programname":102: attempt to index ? (a nil value)
turtle: "programname":2: attempt to index (a nil value)


Can anyone tell my why or what im doing wrong?
Or just help me get my own program together?

Thanks so far! and sorry if there are some mistakes. English isnt my first language as im from Germany. I hope you guys could understand everything anyways.
Have a nice day! :)

#2 HPWebcamAble

  • Members
  • 933 posts
  • LocationWeb Development

Posted 12 August 2015 - 05:09 AM

The turtle's error is likely because you don't OpenCCSensors installed. If you actually do, is there a sensor on the left of the turtle?
http://www.computerc...-openccsensors/

The error on the computer is because you don't have Lyqyd's touchpoint API, found here:
http://www.computerc...touchpoint-api/
Make sure to download it as 'touchpoint'


View PostObsidia, on 12 August 2015 - 04:15 AM, said:

Can anyone tell my why or what im doing wrong?
Or just help me get my own program together?

I'd recommend trying to get this one working, it would take a good amount of time to replicate it :P

#3 Obsidia

  • Members
  • 36 posts

Posted 12 August 2015 - 05:56 AM

View PostHPWebcamAble, on 12 August 2015 - 05:09 AM, said:

The turtle's error is likely because you don't OpenCCSensors installed. If you actually do, is there a sensor on the left of the turtle?
http://www.computerc...-openccsensors/

The error on the computer is because you don't have Lyqyd's touchpoint API, found here:
http://www.computerc...touchpoint-api/
Make sure to download it as 'touchpoint'


View PostObsidia, on 12 August 2015 - 04:15 AM, said:

Can anyone tell my why or what im doing wrong?
Or just help me get my own program together?

I'd recommend trying to get this one working, it would take a good amount of time to replicate it :P

Im not completly sure if CCsensors are installed. The computer works now tho. Thanks for that. Now hes searching for the turtle.
Now to the turtle: I used a wireless turtle from computercraft itself with the wireless modem on its left. is there anything to add to it?

thanks for your help :)

#4 Obsidia

  • Members
  • 36 posts

Posted 12 August 2015 - 06:06 AM

Smal update: In the turtle code it says "sensor.wrap("right")" - what kind of sensor should be put on the right?
Shouldnt it be like "rednet.open("left")" ? as HPWebcamAble already said the wireless modem of the turtle is on the right.. so what should be bound to the right?





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users