Jump to content




Error: "You are not attached to this computer" when using redstone conduits and a chest peripheral on a single computer

peripheral lua computer

3 replies to this topic

#1 LvW

  • New Members
  • 2 posts

Posted 03 October 2015 - 07:18 PM

When connecting two or more redstone conduits to the computer and at the same time having a peripheral.wrap on a chest, any chest command (eg .getStackInSlot()) results in an error message which I've never encountered before:

"Java Exception Thrown: java.lang.RuntimeException: You are not attached to this Computer"

I tried restarting everything about 10 times and I tried a number of conduit/chest configurations and I could only find that the error only appears in the setup described above. Whenever there is only one conduit alongside the chest connected to the computer, it works fine. So does any number of conduits without the chest.

This problem occurred after I updated to the latest FTB infinity 1.11.2. My setup worked perfectly fine before that.

Did something change in the newest computercraft version? or is this a bug?

#2 Lyqyd

    Lua Liquidator

  • Moderators
  • 8,454 posts

Posted 03 October 2015 - 10:22 PM

Using chests as peripherals is something added by OpenPeripheral, so if it's a bug with a mod, it's their bug, not ComputerCraft's.

#3 Bomb Bloke

    Hobbyist Coder

  • Moderators
  • 7,099 posts
  • LocationTasmania (AU)

Posted 03 October 2015 - 11:03 PM

I see this report, which in turn leads to this one.

#4 LvW

  • New Members
  • 2 posts

Posted 04 October 2015 - 04:04 PM

Thanks for the replies.
As Lyqyd mentioned, OpenPeripheral was propably the cause because using a previous version of all OpenMods mods solved the problem:
OpenBlocks 1.4.4 --> 1.4.3
OpenPeripheralCore 1.2 --> 1.1.1
OpenPeripheralIntegration 0.3 --> 0.2.2
OpenPeripheralAddons 0.4 --> 0.3.1b
OpenModsLib 0.8 --> 0.7.3





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users