Jump to content




[CC1.5]ComputerCraft Emulator V0.57 (February 19th)


399 replies to this topic

#101 Xtansia

  • Members
  • 492 posts
  • LocationNew Zealand

Posted 04 September 2012 - 06:11 AM

View Postcraniumkid22, on 04 September 2012 - 04:44 AM, said:

I have a small(maybe) suggestion: If you could have some sort of indicator for the redstone signals going out, that would be good. I tried using the emulator, and realized that using signals between the boxes doesn't work! :D/>
So it would be a neat feature to add.

Yeah, I just had a quick think about it and this is a quick mockup idea I had
Spoiler
where the redstone 'joint' is a moveable module, which would colour itself accordingly, and you can 'create' new ones with the press of a button and delete them also,
And each terminal has little 'nodes' at the bottom for each 'side' which you can click on and then click a joint and they will 'connect' so you could have multiple terminals connected to one joint.
There would also be a bundled version

#102 Cranium

    Ninja Scripter

  • Moderators
  • 4,031 posts
  • LocationLincoln, Nebraska

Posted 04 September 2012 - 02:34 PM

Yeah, that seems about right. For multiple connections, just add more labels, and for easy identification, have the connections display when hovering. It would look like: "Back, redstone, computer #". You would just add connections as necessary. If there is no computer to connect with, just list none.

#103 Leo Verto

  • Members
  • 620 posts
  • LocationOver there

Posted 04 September 2012 - 04:23 PM

This emulator is awesome and makes working on a project a lot easier than having to give minecraft tons of ram,
I'm looking forward to rednet and redstone simulation.

Are you going to update it to the next CC version (probably 1.42) once it's out?

Edited by Leo Verto, 06 September 2012 - 05:10 PM.


#104 filipkwro

  • Members
  • 21 posts
  • LocationPoland (in Europe)

Posted 06 September 2012 - 03:07 PM

Works on Windows 7 home premium.

#105 GilDev

  • Members
  • 7 posts
  • LocationFrance

Posted 11 September 2012 - 04:29 PM

Is the emulator always in development? Because I really need a Mac version. =/ Oh and if you want, maybe I can try it on my RaspBerry Pi, just to see if it work. =)

#106 PixelToast

  • Signature Abuser
  • 2,265 posts
  • Location3232235883

Posted 11 September 2012 - 04:34 PM

works perfectly on vista x86
although when you use a high font scale it tiles the border

#107 GilDev

  • Members
  • 7 posts
  • LocationFrance

Posted 11 September 2012 - 05:01 PM

Okay, so I just tried the emulator on my RaspBerry Pi, the launcher is working great but when I start, it say it can't detect the installation (but I put it in a mods folder in the jar folder) and if I launch if from the terminal, after pressing the start button I have a lot of error messages and it say "Possible cause: can't load IA 32-bits, so on a ARM-bit platform". It say also errors with LWJGL and "Cannot open shared object file".
I hope it will work a day! =)

Sorry for my bad English.

#108 Rangicus

  • Members
  • 84 posts
  • LocationDeath City

Posted 14 September 2012 - 09:52 PM

When I run the EMU all the comps are shutdown and I can't turn them back on.

#109 Cranium

    Ninja Scripter

  • Moderators
  • 4,031 posts
  • LocationLincoln, Nebraska

Posted 14 September 2012 - 09:55 PM

View PostRangemuldee, on 14 September 2012 - 09:52 PM, said:

When I run the EMU all the comps are shutdown and I can't turn them back on.
You need to manually select your minecraft installation then. If you have both tekkit and CC, then you need to select one or the other. I usually select tekkit, since CCEmu is only updated to 1.3, and I have already updated to 1.41 on my CC install.

#110 makerimages

  • Members
  • 236 posts

Posted 15 September 2012 - 10:10 AM

file path not working on win7

#111 Mikeyjd25

  • New Members
  • 7 posts

Posted 18 September 2012 - 02:35 AM

Thank you so much for this, it really speeds up the development of my computer craft OS, because there isn't the overhead of having to have minecraft open :)/>

To sum this up in one word:
awesome :D/>

It runs great on my system:

/----------------------\
|~windows~7~64-BIT~~~~~|
|~16GB~ram~~~~~~~~~~~~~|
|[email protected]~|

\----------------------/

#112 IceCream

  • New Members
  • 28 posts

Posted 21 September 2012 - 07:01 PM

Its not working, It's linking up to my minecraft cc and the monitors are like they are switched off.

#113 Xtansia

  • Members
  • 492 posts
  • LocationNew Zealand

Posted 21 September 2012 - 11:04 PM

View PostIceCream, on 21 September 2012 - 07:01 PM, said:

Its not working, It's linking up to my minecraft cc and the monitors are like they are switched off.

What version of CC?
And error log from console/command prompt/terminal ?

#114 wgcfatalahot

  • New Members
  • 3 posts

Posted 24 September 2012 - 09:57 PM

Would it be possible to make an App version of this for iPhone/iPod in the future? If there was an app for this, I would be a VERY happy Tekkiter (if that's even a word) :P/>

#115 Xtansia

  • Members
  • 492 posts
  • LocationNew Zealand

Posted 25 September 2012 - 12:31 AM

View Postwgcfatalahot, on 24 September 2012 - 09:57 PM, said:

Would it be possible to make an App version of this for iPhone/iPod in the future? If there was an app for this, I would be a VERY happy Tekkiter (if that's even a word) :P/>

No I won't be,
Due to the fact I down own an apple computer, or a iPhone/iPod,
And it cost ~100USD just to get the license to dev apps for iPhone/iPod.
And several other reasons.

The only other device that has any real chance of being ported to is android.

#116 Cranium

    Ninja Scripter

  • Moderators
  • 4,031 posts
  • LocationLincoln, Nebraska

Posted 25 September 2012 - 01:34 AM

Any news on the update to 1.41 (or 1.42, though not holding my breath)?

#117 Xtansia

  • Members
  • 492 posts
  • LocationNew Zealand

Posted 25 September 2012 - 02:37 AM

View PostCranium, on 25 September 2012 - 01:34 AM, said:

Any news on the update to 1.41 (or 1.42, though not holding my breath)?

Yeah,
I've had a lot more important things going on so this hasn't been top priority,
I did have a /working/ build using CC1.41 but a couple people I had testing it experienced some major bugs.
I'm /working/ on a CC1.42 version on and off, so I really don't know,
Luckily I have school holidays coming up next week for 2 weeks I should be able to get a fair bit done.

#118 Cranium

    Ninja Scripter

  • Moderators
  • 4,031 posts
  • LocationLincoln, Nebraska

Posted 25 September 2012 - 02:43 AM

Can't wait. Still one of my favorite tools with working on ComputerCraft. I have this installed to my flash drive, and take it to work and use it at home.

#119 Xtansia

  • Members
  • 492 posts
  • LocationNew Zealand

Posted 27 September 2012 - 01:06 PM

Just me posting some stuffs,
An album of dev preview images: http://imgur.com/a/M8TRj
A quick wee dev preview video:


Also I'm quite often online on the irc in both #computercraft and #cc-emu,
If you would like to test the dev build just ask me on irc when I'm online or message me here on the forums.

//Edit: If anyone is willing to/wants to donate I would greatly appreciate it, just message me here on the forums, the money would go into funding the hosting of cc-emu and some features I'm planning, and just the general development of cc-emu.

#120 MysticT

    Lua Wizard

  • Members
  • 1,597 posts

Posted 27 September 2012 - 04:54 PM

Something that would be very useful is being able to choose the computer id when opening a new one. So you can work on computer #10 with only that one open instead of having 9 useless terminals around.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users