Jump to content




Speedometer - ComputerCraft Rating Program

utility lua computer

12 replies to this topic

#1 Checco2212

  • Members
  • 59 posts
  • LocationSomewhere in Europe

Posted 27 December 2016 - 06:47 PM

Speedometer

Fully customizable BIOS experience

V 1.1.0


Some days ago I found an old and almost completed version of this program in my archives, so I decided to work on it and finally publish it. In these days I completely recoded it in a single-file format.

Type of tests:
  • Fast
  • Complete
  • Only CPU
  • Only GPU
Interesting features:
  • Using the ChartsAPI you can see graphically your results
  • Update notifier
Screenshot time!
Spoiler

Download

To download Speedometer on your computer type


pastebin get gn2LeCim <name>


Changelog

Spoiler

Don't forget to post your fast test result!

Edited by Checco2212, 31 December 2016 - 01:21 PM.


#2 CrazedProgrammer

  • Members
  • 495 posts
  • LocationWageningen, The Netherlands

Posted 27 December 2016 - 11:08 PM

Well polished and a pretty cool interface! :D

I'm kind of confused why the quick test gives slightly higher (around 7% or so) results than the advanced test.

My result (quick test):
Spoiler
Note that I'm on my laptop right now running CCEmuRedux.

Edited by CrazedProgrammer, 27 December 2016 - 11:12 PM.


#3 Checco2212

  • Members
  • 59 posts
  • LocationSomewhere in Europe

Posted 27 December 2016 - 11:37 PM

View PostCrazedProgrammer, on 27 December 2016 - 11:08 PM, said:

Well polished and a pretty cool interface! :D

I'm kind of confused why the quick test gives slightly higher (around 7% or so) results than the advanced test.

My result (quick test):
Spoiler
Note that I'm on my laptop right now running CCEmuRedux.

Nice to hear you liked the graphic!
About the tests: the CPU test uses an exponential growing algorithm so it's a bit hard to calibrate. Maybe in the next version I'll improve it ;)

#4 Pyuu

  • Members
  • 203 posts

Posted 28 December 2016 - 03:55 AM

Posted Image

#5 Xerxes

  • Members
  • 55 posts
  • LocationSwitchCraft

Posted 28 December 2016 - 04:24 AM

Cool. Here's what a computer on SwitchCraft got for the quick test:
Posted Image

Here's the advanced test:
Posted Image


I don't really think these tests have any merit - but SwitchCraft can actually have several of these tests running at the same time with roughly the same results as these due to SquidDev's Cobalt Lua engine and multithreading the coroutines.

#6 Checco2212

  • Members
  • 59 posts
  • LocationSomewhere in Europe

Posted 28 December 2016 - 01:34 PM

View PostPyuu, on 28 December 2016 - 03:55 AM, said:

Posted Image

I thought I'd fixed this problem... on MC and CCEmuRedux it's working fine...

#7 TheRockettek

  • Members
  • 547 posts
  • LocationRem is best girl

Posted 29 December 2016 - 10:35 AM

I got a -2 gpu test...

#8 houseofkraft

  • Members
  • 170 posts
  • LocationUSA

Posted 29 December 2016 - 01:59 PM

You need a OpenComputers speedtest program because the GPU or CPU or even memory can actually be slow

Here are my results...

Basic Mode:
CPU: 80/100
GPU: 56/100
Total: 68/100

Advanced Mode:
CPU: 73/100
GPU: 54/100
Total: 63.5/100

#9 Checco2212

  • Members
  • 59 posts
  • LocationSomewhere in Europe

Posted 29 December 2016 - 02:25 PM

View PostTheRockettek, on 29 December 2016 - 10:35 AM, said:

I got a -2 gpu test...

Do you have any screenshot?

Edited by Checco2212, 29 December 2016 - 02:38 PM.


#10 TheRockettek

  • Members
  • 547 posts
  • LocationRem is best girl

Posted 29 December 2016 - 07:25 PM

View PostChecco2212, on 29 December 2016 - 02:25 PM, said:

View PostTheRockettek, on 29 December 2016 - 10:35 AM, said:

I got a -2 gpu test...

Do you have any screenshot?
Well not now i dont.

I got a too long without yielding on the gpu test tho

Just managed to get -8 XD

Posted Image

Oh and this.

Posted Image

Oh, its coz of the negative...

#11 Incinirate

  • Members
  • 216 posts
  • LocationDanktown, Memeland

Posted 31 December 2016 - 03:24 AM

Not sure if this is a bug, but
Posted Image
Ran on CCEmuX

Edit: I investigated and found out that it's because speedometer uses os.time which is constantly 10 in ccemux
Edit 2: After writing a quick polyfill, CCEmuX gets these results
Posted Image

Edited by Incinirate, 31 December 2016 - 03:52 AM.


#12 Checco2212

  • Members
  • 59 posts
  • LocationSomewhere in Europe

Posted 31 December 2016 - 01:22 PM

V 1.1.0 online!

Fixed:

View PostTheRockettek, on 29 December 2016 - 10:35 AM, said:

Posted Image



View PostIncinirate, on 31 December 2016 - 03:24 AM, said:

Posted Image
PS: negative results will not be saved anymore

Edited by Checco2212, 31 December 2016 - 01:23 PM.


#13 houseofkraft

  • Members
  • 170 posts
  • LocationUSA

Posted 31 December 2016 - 05:15 PM

I'll have to try it on OC with a CraftOS emulator and see what happens :)





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users