Jump to content




CC-copy -- Your solution to servers without HTTP API



40 replies to this topic

#21 Orwell

    Self-Destructive

  • Members
  • 1,091 posts

Posted 17 December 2012 - 03:43 AM

No, it can be any extension. Run this command in the command line to see if it's not something like "chat.lua.txt": Edit: this will list all the files by their full name.
dir C:\Users\ads\Desktop\cc-copy_bin\
Also, be sure to put the lua program in that same directory.

Edit: You can also just type this in command line:
notepad C:\Users\ads\Desktop\cc-copy_bin\chat.lua
Notepad will open, then copy the content of the program into notepad and save it. After that, dissy's command should work just fine.

#22 Kingston

  • New Members
  • 4 posts

Posted 17 December 2012 - 03:48 AM

Not working :/

Edit: Not working even after your edit, comrade Orwell.

#23 Kingston

  • New Members
  • 4 posts

Posted 17 December 2012 - 04:00 AM

I quit.

#24 Mr. Fang

  • Members
  • 82 posts

Posted 21 December 2012 - 10:16 AM

Works like a charm after about 3 minutes of fiddling with it.

#25 Orwell

    Self-Destructive

  • Members
  • 1,091 posts

Posted 21 December 2012 - 10:18 AM

Cool. :) What did you fiddle with if I may ask? I'd be happy to make it more user friendly if you have suggestions.

#26 Mr. Fang

  • Members
  • 82 posts

Posted 21 December 2012 - 10:59 AM

Here's what I did.
1.I placed the cc-copy.exe on my desktop
2. I opened the CMD thingy via Start+R
3. I created a .txt on my desktop named text.txt then opened it
4. Started Tekkit and opened a computercraft computer on the server that doesn't have HTTP
5. Typed "edit startup" onto my ComputerCraft Computer
6. saw this entire msg when I typed out what you asked:
"C:\Users\Fang>\desktop\CC-copy.exe -w Tekkit -t 5 -s 15 --old desktop\text.txt "
7.Ran the program (pressed enter) with my notepad open and my Tekkit open to the ComputerCraft Computer's file edit screen
8.Watched as it typed it for me
9.Checked the code and made sure it was all right...I found some things in the beginning that looked wrong but idk...I'll look later into that
10.Was done!

#27 ti07shadow

  • Members
  • 4 posts

Posted 01 January 2013 - 06:09 PM

Yea I have a bit of a issue with this.. When I type in

C:\Users\David\Desktop\cc-copy_bin\CC-copy.exe -w Tekkit -t 1 -s 4000 test.txt

it gives me the following

4000 test.txt
Found Tekkit Window
Couldn't open file 'test.txt'.
Done writting file

#28 Orwell

    Self-Destructive

  • Members
  • 1,091 posts

Posted 01 January 2013 - 11:41 PM

View Postti07shadow, on 01 January 2013 - 06:09 PM, said:

Yea I have a bit of a issue with this.. When I type in

C:\Users\David\Desktop\cc-copy_bin\CC-copy.exe -w Tekkit -t 1 -s 4000 test.txt

it gives me the following

4000 test.txt
Found Tekkit Window
Couldn't open file 'test.txt'.
Done writting file
That's because the file test is not in the directory you're running the command from. Best way is to put all involved files in the same directory and cd to it. Then run the commands. Or else you can use the full path to test.txt in the command.

#29 SteakSAUSE

  • New Members
  • 2 posts

Posted 02 January 2013 - 03:39 PM

I'm trying to use this program with the FTB MindCrack Pack, but I am unsure what the window name would be, anyone have an idea?

#30 Orwell

    Self-Destructive

  • Members
  • 1,091 posts

Posted 02 January 2013 - 04:08 PM

It's just the title of the window running minecraft. :) I just checked, and in your case it would be "MindCrack Pack" (put it in between quotes after the -w ).

#31 DjKiDD

  • Members
  • 4 posts

Posted 19 January 2013 - 11:31 AM

THANK YOU!
This is an amazing help on the server I play on :P

I keep experiencing this same bug... it always duplicates the last character of the code being uploaded

#32 Orwell

    Self-Destructive

  • Members
  • 1,091 posts

Posted 22 January 2013 - 06:38 AM

View PostDjKiDD, on 19 January 2013 - 11:31 AM, said:

THANK YOU!
This is an amazing help on the server I play on :P

I keep experiencing this same bug... it always duplicates the last character of the code being uploaded
Yeh, I seem to remember that it can be fixed by putting one empty line under the code.

#33 AkaZombie

  • New Members
  • 2 posts

Posted 10 February 2013 - 06:57 AM

View PostKingston, on 17 December 2012 - 03:39 AM, said:

It still can't find the specified file. Are you sure it must be a .lua?
Perhaps you have to drag the chat file into cmd like the CC-Copy.exe

#34 Orwell

    Self-Destructive

  • Members
  • 1,091 posts

Posted 10 February 2013 - 07:16 AM

View PostAkaZombie, on 10 February 2013 - 06:57 AM, said:

View PostKingston, on 17 December 2012 - 03:39 AM, said:

It still can't find the specified file. Are you sure it must be a .lua?
Perhaps you have to drag the chat file into cmd like the CC-Copy.exe
Chat file? :mellow:

#35 superaxander

  • Members
  • 609 posts
  • LocationHolland

Posted 15 February 2013 - 03:46 AM

View PostOrwell, on 10 February 2013 - 07:16 AM, said:

View PostAkaZombie, on 10 February 2013 - 06:57 AM, said:

View PostKingston, on 17 December 2012 - 03:39 AM, said:

It still can't find the specified file. Are you sure it must be a .lua?
Perhaps you have to drag the chat file into cmd like the CC-Copy.exe
Chat file? :mellow:
The name of his file was chat.lua

#36 CupricWolf

  • Members
  • 86 posts
  • LocationColorado, USA

Posted 05 March 2013 - 01:51 AM

I notice that in
void stopEditingFile() {
    sendKey(VK_CONTROL);
    sendKey(VK_RETURN);
    sendKey(VK_CONTROL);
    sendKey(VK_RIGHT);
    sendKey(VK_RETURN);
}
you don't use the interval between each
sendKey()
. Just thought you might want to know. I couldn't save the files on my server, it types it out just fine but then sends the final key strokes much too quickly.

#37 icecube45

  • Members
  • 38 posts

Posted 17 March 2013 - 11:24 AM

Hey, used this program a while ago, and it doesnt seem to work now, It will switch to the tekkit window, but nothing will happen, it will type it into any other program however

#38 Mads

  • Members
  • 604 posts
  • LocationCopenhagen, Denmark

Posted 17 March 2013 - 08:12 PM

Where did you get the BYTE type? Is it in windows.h, or did you just typedef char BYTE; ?
Anyway, nice program. Can't test it though, I'm on Linux.

#39 AliveGhost

  • Members
  • 9 posts

Posted 16 July 2013 - 05:32 PM

Hey,

It all seems to be running okay, apart from it says "Couldn't open file 'desktop\mainprog'. How can I get the cmd to open it?

Cheers,
AliveGhost

#40 Orwell

    Self-Destructive

  • Members
  • 1,091 posts

Posted 17 July 2013 - 07:18 AM

View PostAliveGhost, on 16 July 2013 - 05:32 PM, said:

Hey,

It all seems to be running okay, apart from it says "Couldn't open file 'desktop\mainprog'. How can I get the cmd to open it?

Cheers,
AliveGhost
What exact command you're running? I might be able to help you better that way. The trick is to use the full path name in between quotes. E.g.:
CC-copy.exe "C:\Users\username\desktop\mainprog"






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users