Jump to content




Variable Size Quarry (now with Super Ore Quarry™)

turtle

593 replies to this topic

#21 sjkeegs

  • Members
  • 75 posts

Posted 10 January 2013 - 03:51 AM

You appear to have deleted the pastebin link for the main application, and replaced it with the spoiler.

#22 MrHohenheim

  • Members
  • 26 posts
  • LocationDebrecen

Posted 10 January 2013 - 06:05 AM

here http://pastebin.com/uGBP137c

#23 civilwargeeky

  • Members
  • 392 posts

Posted 10 January 2013 - 06:19 AM

Thanks MrHohenheim, I will put the fixed pastebin, since I can't post my own code to pastebin from my phone (which is why I put proper code in a spoiler)

#24 anonimo182

  • Members
  • 252 posts
  • LocationIn the universe

Posted 10 January 2013 - 06:31 AM

This really needs the rednet sending to screen, otherwise really nice program!! Can also optimize time by mining by trhee rows at time instead of two, if the left height is divisible by 3

#25 Heracles421

  • Members
  • 258 posts

Posted 10 January 2013 - 06:52 AM

I can help you with the Rednet things if you want

#26 anonimo182

  • Members
  • 252 posts
  • LocationIn the universe

Posted 10 January 2013 - 06:54 AM

And me too

#27 MrHohenheim

  • Members
  • 26 posts
  • LocationDebrecen

Posted 10 January 2013 - 07:35 AM

i need this quarry for inverted working :D i want chop the forest :P

#28 Heracles421

  • Members
  • 258 posts

Posted 10 January 2013 - 07:41 AM

View PostMrHohenheim, on 10 January 2013 - 07:35 AM, said:

i need this quarry for inverted working :D/> i want chop the forest :P/>

Why don't you just place a turtle up over some dirt scaffolding, an use the quarry program?

#29 MrHohenheim

  • Members
  • 26 posts
  • LocationDebrecen

Posted 10 January 2013 - 08:14 AM

redwood and fir trees so high.... and i want sometimes clear hills etc.. not want always digging :)

#30 civilwargeeky

  • Members
  • 392 posts

Posted 10 January 2013 - 11:26 AM

Alright. So, here is my plan for taking this program forward a bit
1. [TimeFrame: Before Monay] Add Rednet Program to send information to a host computer with a receiver program.
2. [TimeFrame: Shortly after step 1] Add arguments to quarry program to bypass start screen if dimensions exist
3. [TimeFrame: Sometime this month] Rewrite the way it does quarries. After I do this step, it will mine 3 at a time until the last row, where it will mine depending on the height. (hopefully much faster and easier to use)

Now on the topic of step 1, I am planning on including dimensions, percent complete, blocks moved, blocks remaining, blocks mined, and fuel level in the sent information. It will use os.queueEvent() to transfer data to a modular master program, to make things more simple. Any more things you would like to see?

#31 civilwargeeky

  • Members
  • 392 posts

Posted 10 January 2013 - 11:28 AM

View Postanonimo182, on 10 January 2013 - 06:31 AM, said:

This really needs the rednet sending to screen, otherwise really nice program!! Can also optimize time by mining by trhee rows at time instead of two, if the left height is divisible by 3
Coming soon :D

#32 civilwargeeky

  • Members
  • 392 posts

Posted 10 January 2013 - 01:04 PM

Hey Mr. Hohenheim, I just uploaded an inverted version for you, the only thing changed is that it's height functions are reversed. Hope you like it :) I'll have one you may like more out later.

#33 MrHohenheim

  • Members
  • 26 posts
  • LocationDebrecen

Posted 10 January 2013 - 02:46 PM

thx :) i finished too the rewrite the code working cool die big trees hills :D

#34 Blackbeared

  • Members
  • 4 posts

Posted 11 January 2013 - 05:40 AM

I also think I found my own problem as to why the turtle stopped without giving an error. I placed a world anchor there to keep the chunk loaded. Didn't see that World Anchors now need fuel to keep chunks loaded. So it probably just unloaded. I have to to test to make sure it's that, but I believe it is xD.

Otherwise still awesome script :).

#35 killaking319

  • New Members
  • 1 posts

Posted 11 January 2013 - 06:29 PM

Error = ' Bios:338: [string"quarry"]:74: ')' expected '
any ideas?

#36 civilwargeeky

  • Members
  • 392 posts

Posted 11 January 2013 - 07:06 PM

View Postkillaking319, on 11 January 2013 - 06:29 PM, said:

Error = ' Bios:338: [string"quarry"]:74: ')' expected '
any ideas?
Nope. That section shouldn't give an error. Try recopying it, maybe remove the comment there, but the code in the pastebin is fine there.

#37 Blackbeared

  • Members
  • 4 posts

Posted 12 January 2013 - 10:23 AM

Don't know if others got this, I downloaded the new version (I had the same situation with the previous version), for some reason I can run it, for example Length: 15, width: 15, height: 124, and it says the Usual, Job very big, auto emptying on.

Then it just stands there and does nothing. On the turtle it gives this message:

Blocks Mined

Percentage Complete

And that's it. I've seen a 'similar' post on the bug forum section but that's when he just goes offline or when he leaves the Nether. Mine doesn't work with either a normal Chunk loader (which fully loads the chunk, I've made sure it wasn't that) or when I am standing there myself. I was wondering if this is a problem that I can solve myself, that possible have appeared before.

Thanks!

#38 civilwargeeky

  • Members
  • 392 posts

Posted 14 January 2013 - 06:46 PM

Ok. Updated the program to 2.3.3
Changes:
  • Added rednet support. To work, the second argument on quarry must be "true" (without quotes)
  • Fixed a bug in the counting where it wouldn't count anything as cobble
  • May have fixed a few other minor bugs

And to those that had trouble with very large height values, maybe I fixed it, because with this version I tried 2, 2, 124 and had no problems.
If you find any bugs, please post them here so I can fix them.
I am posting an updated video on use tomorrow.

#39 MrHohenheim

  • Members
  • 26 posts
  • LocationDebrecen

Posted 16 January 2013 - 02:08 AM

hmm can u make video for this rednet things?

my turtle not send signal for Computer hmm

#40 civilwargeeky

  • Members
  • 392 posts

Posted 16 January 2013 - 04:08 PM

Uploaded new youtube video. Sorry the sound is off by a second or two, had a problem converting





3 user(s) are reading this topic

0 members, 3 guests, 0 anonymous users