Jump to content




ComputerCraft 1.3.1 for Minecraft 1.1 (BackPort)


31 replies to this topic

#21 cant_delete_account

  • Members
  • 484 posts

Posted 30 March 2012 - 08:36 PM

Are you gonna backport 1.32 for 1.1? It would be awesome if you could.

#22 Evis

  • New Members
  • 24 posts

Posted 31 March 2012 - 03:24 AM

Sweet!

Client Install Instructions

Doing this on Win7:

1. Use window explore to browse to: system:UsersusernameAppDataRoaming.minecraftmods

You can get there easily by type %appdata% in the address bar of windows explore.

2. Create a folder on your desktop called CC-Backup, you'll use this later.

3. Locate the ComputerCraft folder at local address above and select cut and then paste the whole folder in CC-Backup on your desktop.

4. Locate ...userAppDataRoaming.minecraftconfig and repeat step 3 for the mod_ComputerCraft.cfg file. This creates a backup of the older mod. This doesn't backup your computers, which are stored locally in your saves

5. Once complete, add the computer craft folder from the zip into mods

6. Start a SP game. Test the screen. You should be good to go.

Note: Now I need to find an update to the IC texture pack since it didn't display at first. :o/>

Tested: OK

Server Install Instructions

Coming as soon as I break my server...

#23 Aeroxima

  • Members
  • 3 posts

Posted 16 April 2012 - 08:34 PM

View Postnrgamp, on 17 March 2012 - 03:34 AM, said:

View Postthesbros, on 14 March 2012 - 03:50 AM, said:

View Postnrgamp, on 14 March 2012 - 12:09 AM, said:

When I do as stated my server runs but my client crashes and gives me this error: java.lang.IllegalArgumentException: Slot 209 is already occupied by [email protected] when adding [email protected]

That's a block ID error. You can fix that by going into Railcraft or CC's config file. Usually located at .minecraft/config, and changing the conflicting block ID.
I edited the railcraft config file to change the block Id and now when I start it up it gives me an error but b4 I can read it, it closes out also I am using the technic launcher using tekkit.

View PostCasper7526, on 17 March 2012 - 03:44 AM, said:

ModLoader.txt stores the last error.

I was having these problems too, here's how I got through it (with Tekkit 2.1.1 client):

1. ModLoader.txt doesn't necessarily show the error at the end of the file, search for "THROW" or just scroll up and look for things that look wrong. I thought the file was incomplete because of the crashing, but it was just above kind of hidden.

2. The second error after changing the item ID was because the number I entered (6010) was apparently "out of bounds." It was way too high (I was trying to get something that wouldn't be taken).

3. Used item ID 214 for the turtle, in ".techniclaunchertekkitconfigmod_CCTurtle.cfg":
turtleBlockID=214

It now loads up and is working so far (with monitors yay). Thanks all and I hope this clears it up for somebody else too. (I wish it was easier to see which itemIDs were available, especially when TME is showing me different numbers and I can't even use it when the game is crashing.)

#24 PixelToast

  • Signature Abuser
  • 2,265 posts
  • Location3232235883

Posted 21 April 2012 - 09:32 PM

im running a tekkit server and everything works fine but the monitor api isnt installed for some reason

#25 Leo Verto

  • Members
  • 620 posts
  • LocationOver there

Posted 24 April 2012 - 04:31 PM

View Postabc, on 21 April 2012 - 09:32 PM, said:

im running a tekkit server and everything works fine but the monitor api isnt installed for some reason
Tekkit uses CC 1.3, monitors were implemented in 1.31.
You can install this backport, but in that case, everyone who wants to play on your server would need to install it too but if your players want to play on your and other servers, they would require to switch between CC 1.3 (normal tkkit server) and CC 1.31 (tekkit server with backport).
That's why I personally do not recommend using this for tekkit.

#26 frostyjacks

  • New Members
  • 1 posts

Posted 30 April 2012 - 02:00 PM

Any news on bukkit backport bug where turtle.compare() function always returns true?

Link: http://www.computerc...s-returns-true/

Thanks!

#27 ComputerCraftFan11

  • Members
  • 771 posts
  • LocationHawaii

Posted 01 May 2012 - 05:24 AM

View Postthesbros, on 30 March 2012 - 08:36 PM, said:

Are you gonna backport 1.32 for 1.1? It would be awesome if you could.

1.32 is just 1.31 ported to 1.2.5

#28 djblocksaway

    Epic Coderz

  • New Members
  • 397 posts
  • LocationAustralia

Posted 13 May 2012 - 01:31 PM

minecraft 1.1 is a bit outdated lol :P/>

#29 Leo Verto

  • Members
  • 620 posts
  • LocationOver there

Posted 13 May 2012 - 08:57 PM

View Postdjblocksaway, on 13 May 2012 - 01:31 PM, said:

minecraft 1.1 is a bit outdated lol :P/>
It is, but Tekkit still uses it.

#30 ComputerCraftFan11

  • Members
  • 771 posts
  • LocationHawaii

Posted 13 May 2012 - 09:14 PM

View PostLeo Verto, on 13 May 2012 - 08:57 PM, said:

View Postdjblocksaway, on 13 May 2012 - 01:31 PM, said:

minecraft 1.1 is a bit outdated lol :D/>
It is, but Tekkit still uses it.

Cuz tekkit is outdated :P/>

#31 Leo Verto

  • Members
  • 620 posts
  • LocationOver there

Posted 14 May 2012 - 07:59 PM

View PostComputerCraftFan11, on 13 May 2012 - 09:14 PM, said:

View PostLeo Verto, on 13 May 2012 - 08:57 PM, said:

View Postdjblocksaway, on 13 May 2012 - 01:31 PM, said:

minecraft 1.1 is a bit outdated lol ;)/>
It is, but Tekkit still uses it.

Cuz tekkit is outdated :D/>
Cause tekkit wants to stay compatible. :P/>

#32 jetic

  • New Members
  • 1 posts

Posted 11 October 2012 - 03:20 PM

Can somebody help me plz?
The links are broken... I can't download 1.3.1 anywhere...
Plz, help me...





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users