Jump to content




[1.4.2][SMP/FTB][CC v1.46]Turtle looses his Mining pickaxe after Server Crash


55 replies to this topic

#1 Syli

  • New Members
  • 12 posts

Posted 09 December 2012 - 12:00 AM

ComputerCraft Version: 1.46 Client on a FTB Server

Description of Bug:
After a Server crash my mining Miningturtles looses his Pickaxes, wich are running with a own programmed Mining script, after the server Restarts they where "normal" turtles without his previus Inventory (Inventory was empty), this happend now 2 times.
First time 2 out of 2 Turtes are affected of this bug
Second time only 2 out of 3 turtles are affected (differend Mining programms - eventually the one uneffected stands still, and waited for Input, not shure)

Steps to Reproduce Bug:
The Server Admin wasent online, so i didn't get a chance to get the Server crash log, but if this happends if he is online i will get it next times, to see why the server was crashed, the Server is a small one with 10-20 ppls Online around the clock! If I get the log file i will post it here.


This Bug is very Strange, because you loose the Turtle Inventory aswell as the Turtle Tool.



PS: this is my first Post and i want to thank you for Making this awsome mod. This is a realy good Opertunity to learn the lua Syntax ;)

greetings
Syli

#2 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 09 December 2012 - 12:25 AM

Without a crash log there's absolutely nothing we can do.

#3 g0shujinsama

  • Members
  • 2 posts

Posted 04 January 2013 - 12:46 PM

If it is the same problem we just encountered this on our server and think we figured out what is happening.

It seems to be a known issue with mystcraft not saving dimensions correctly and only happens when a turtle is moving during a crash or restart. The turtle's block and TileEntity end up at different locations which breaks all customization done to the turtle.

Let me know if your problem is also happening in a mystcraft dimension.

#4 sketchypyjamas

  • Members
  • 13 posts

Posted 04 January 2013 - 06:34 PM

The same thing happened to me for this bug: http://www.computerc...turtle-program/

My wireless mining turtle lost its pick and modem after I restarted the server. This was not in a mystworld dimension. It was just in the regular world.

#5 immibis

    Lua God

  • Members
  • 1,033 posts
  • LocationWellington, New Zealand

Posted 06 January 2013 - 02:37 PM

This has happened to me too, in the overworld, without Mystcraft.

#6 richie3366

  • New Members
  • 1 posts

Posted 11 January 2013 - 05:11 AM

Same problem on my server (mc 1.4.6 / cc 1.481), my turtles lost their inventory, programs and their tools/peripherals... very annoying bug :/

#7 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 11 January 2013 - 07:58 AM

Things break on a crash? Surely not. Yet no one has provided us with a crash log.

#8 maclof

  • New Members
  • 1 posts

Posted 13 January 2013 - 04:24 AM

Cloudy: I've had this issue occur a few times on a public server I play on too, however the crashes arn't being caused by ComputerCraft but another mod so I'm unsure what a crash log would do for you.

The problem is if the Turtle is currently active and doing something, such as mining out an area (chunk loaded) when the crash happens, it will reset back to a default Turtle with no label, scripts or modifications (such as upgrading it to a Mining Turtle).

I'll try and replicate this shortly on one of my servers, however I can almost guarantee the crash log will mention nothing to assist you.

#9 drewpyqb

  • Members
  • 1 posts

Posted 17 January 2013 - 08:18 PM

Just had this same issue twice. There was no crash, and no crash report. There was no bug reported onto the log.

1st time: I just barely left the chunk region the turtle was mining in (noone else was in it). When I returned to the chunk a minute later, the turtle had stopped; the name reset; the fuel gone; the inventory empty; and the pick was removed.

2nd time: I had gotten killed while within range of the turtle. Another person was also standing nearby the turtle. When I returned and the person hadn't left, the turtle had reset.

Again, no error reports for either incident. The server did not crash.

Hope this helps.

#10 zeta0134

  • New Members
  • 1 posts

Posted 18 January 2013 - 06:14 AM

Signed up to report a more pointed issue that seems to be related to this. Confirming what other users have posted: a server crash or hang while the turtles are moving causes them to lose their inventory. Non-moving turtles are not affected, and turtles in item form (in the player's inventory) are also safe.

In our case, the crash itself seems to be related to lua coroutines. The server hang was caused by ComputerCraft, and seems to be related to some function attempting to get the ID of the computer. Our networking library uses the os.getComputerID() function in parallel to a thread which runs the turtle's main program, and I suspect that what's happening is the ID is occasionally being requested during a turtle's movement, in a tiny window during which the turtle is also trying to request its ID, and causing the deadlock.

I don't know if this qualifies as a crash log; basically, I used Ctrl+\ to attempt to kill the server during a hang, and got this lovely greeting instead. I don't have the full history of it (I screen my servers, and this was all the scrollback buffer I had) but I'll try to grab a more complete report when it happens again.
Spoiler

Edited by AfterLifeLochie, 29 January 2013 - 09:48 PM.
100% more spoiler.


#11 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 18 January 2013 - 06:35 AM

Yeah last crash is fixed in next version.

#12 KaoS

    Diabolical Coder

  • Members
  • 1,510 posts
  • LocationThat dark shadow under your bed...

Posted 18 January 2013 - 01:35 PM

man cmon. do people not see the bbc code button there. spoiler please

#13 maximal

  • New Members
  • 5 posts

Posted 18 January 2013 - 10:04 PM

I have the same problem, MC 1.4.6 / cc 1.48 SSP. Happens everytime server crash. You can try to reproduce it by making a bunch of turtles dig tunnels then kill a server and start it again.

#14 g0shujinsama

  • Members
  • 2 posts

Posted 28 January 2013 - 10:34 AM

This is definitely reproducible. You don't have to crash a server and there isn't any associated crash report to turn in. It only happens when turtles are moving and maybe only on servers. In our case we are using the Mindcrack mod pack from the FTB Launcher, though I've also encountered the problem in testing with the BetaA and Direwolf20 packs. If the chunk is unloaded while the turtles are moving there is a high probability that the turtle will be reset and lose all peripherals, programs, label, etc... From what I can tell it occurs because the turtle block get separated from its TileEntity momentarily when it is moving. When the chunk is reloaded, the block can't find its Tile Entity so reverts to a basic turtle.

Again, this happens if the chunk is unloaded for any reason: crash, normal shutdown, player leaves the area, etc...

#15 PixelToast

  • Signature Abuser
  • 2,265 posts
  • Location3232235883

Posted 29 January 2013 - 03:53 AM

-snip-
managed to revert a couple

#16 Tabris

  • New Members
  • 2 posts

Posted 29 January 2013 - 06:12 PM

Having this problem on 1.4.7, what i can see thus far:

It will mostly, if not always happen when Minecraft crashes without the opportunity to save the world, that also means there will not be a crashlog. What is happening is that when the world is loaded again for some reason the turtles are assigned new ids, so they lose the tools they had and also their fuel ID and etc. From looking into the save files i can confirm that the files are still there, so there may even be a way to restore the turtles, i however don'tk now enough about how they work to do that

All this i noticed while playing on SSP, not sure how it works on SMP but i believe it's similar. Most of the time it happened because of a completely unrelated bug between InvTweaks and Redpower2 that makes the game freeze if you try to ctrl + shift a type of item into the project table, the game freezes permanently and i have to terminate it on task manager but i believe i also had the same problem when my computer turned off mid play because the power went down.

#17 Luanub

    Lua Nub

  • Members
  • 1,135 posts
  • LocationPortland OR

Posted 01 February 2013 - 07:01 PM

This hit my server today. Took out quite a few turtles, some were totally lost, others just lost any attached peripherals/tools, and one even came back thinking it was an advanced computer and was bricked due to the fact. Had to scrap it. Hopefully a fix for this is coming soon? I'm rather hesitant to use turtles currently....

#18 stylish

  • Members
  • 7 posts

Posted 05 February 2013 - 03:47 PM

I made a program for my turtles to mine a huge quarry and the shortly after I run the program it would either just crash the server or just mine normally. This has been happening rather frequently now... The more turtles I deploy the more likely it crashes,

#19 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 06 February 2013 - 01:22 AM

Crash log?

#20 stylish

  • Members
  • 7 posts

Posted 06 February 2013 - 02:32 PM

 Cloudy, on 06 February 2013 - 01:22 AM, said:

Crash log?

The server just freezes and requires to be force closed. Not really leaving a crash log.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users