Jump to content




[CC 1.5] [MC 1.4.6/1.4.7] [SMP] Xfel's peripherals - New cable appearance!

peripheral api

524 replies to this topic

#341 sylphio

  • Members
  • 20 posts

Posted 11 August 2012 - 08:56 AM

hello,

Did a test of the 1.8.3 bukkit version, first, i was getting a connection error due to a non-matching peripheral cable version between the bukkit server 1.02 and the client package 1.01.
I bypassed the problem by removing the peripheral mod class from the archive but when use the matter database api or the inventory api i get a error about a unknow native.

Call to peripheral.gettype return the correct value but the number of element of peripheral.getMethods("anysidewithdborinventory") is always zero.

Thank

#342 Xfel

    Peripheral Designer

  • Members
  • 515 posts

Posted 11 August 2012 - 10:45 AM

I'm sorry, but I can't reproduce that bug. So wait for the next release.

#343 Umpani

  • New Members
  • 13 posts

Posted 11 August 2012 - 11:10 AM

View Postsylphio, on 11 August 2012 - 08:56 AM, said:

hello,

Did a test of the 1.8.3 bukkit version, first, i was getting a connection error due to a non-matching peripheral cable version between the bukkit server 1.02 and the client package 1.01.
I bypassed the problem by removing the peripheral mod class from the archive but when use the matter database api or the inventory api i get a error about a unknow native.

Same problem here, although i did not try to bypass the problem:
There is a version mismatch of CCCable between arp-client-1.2.5.zip (1.0.1 in mcmod.info/mod_CCPeripheralCable.info) and arp-bukkit-1.2.5.zip (v1.0.2 in in mcmod.info/mod_CCPeripheralCable.info) which prevents clients to connect to the bukkit server when using the provided downloads without modification.

Cheers,
Umpani

Edit:

This portion of the Bukkit server's server.log might help to track down the problem. It seems that the client reports "CCPeripheralCable v1.0" while the server is expecting "mod_CCPeripheralCable v1.0.2".
Also, in my non-existent knowledge about MC modding, i found out that simply adjusting the in mcmod.info and mod_CCPeripheralCable.info seemed to have no effect on the version number the client reports to the server.

2012-08-11 13:57:47 [INFO] Umpani joined with: [CodeChickenCore 0.5.3, MinecraftForge 3.3.8.164, NotEnoughItems 1.2.2.4, ReiMinimap v3.2_04 [1.2.5], IC2 v1.97, IC2AdvancedMachines v4.0, MetallurgyFishing 1.0.0, ComputerCraft 1.33, CCPeripheralCable v1.0, BuildCraftCore 2.2.14, BuildCraftBuilders 2.2.14, BuildCraftEnergy 2.2.14, BuildCraftFactory 2.2.14, BuildCraftTransport 2.2.14, AdditionalPipes 2.1.3 (Minecraft 1.2.5, Buildcraft 2.2.14, Forge 3.0.1.75), RedPowerMachine 2.0pr5b2, ccSensors MC1.2.5 Build017pr1, CCTurtle 1.33, mocreatures v3.6.2 (MC 1.2.5), EnderStorage 1.1.3, ExtraBees 1.2.1, RedPowerWorld 2.0pr5b2, Forestry 1.4.8.6, IC2NuclearControl v1.1.10, ImmibisCore 49.1.1, InvTweaks 1.41b (1.2.4), MAtmos_forModLoader r12 for 1.1.x, ModularForceFieldSystem rev7, IC2_ChargingBench 1.95b, CompactSolars 2.3.2, IronChest 3.8, RedPowerCore 2.0pr5b2, NetherOres 1.2.5R1.2.2, PowerConverters 1.2.5R1.3.4, Railcraft 5.3.3, RedPowerControl 2.0pr5b2, RedPowerLighting 2.0pr5b2, RedPowerLogic 2.0pr5b2, RedPowerWiring 2.0pr5b2, TubeStuff 49.1.2, Balkon's WeaponMod 1.2.5 v8.6.0, WirelessRedstoneCore 1.2.2.3, WirelessRedstoneAddons 1.2.2.3, WirelessRedstoneRedPower 1.2.2.1, ImmiChunkLoaders rev3.2, CCAdvancedResourceProcessing v1.8]
2012-08-11 13:57:47 [INFO] Umpani was disconnected because they are missing the following mods mod_CCPeripheralCable v1.0.2.


#344 Xfel

    Peripheral Designer

  • Members
  • 515 posts

Posted 11 August 2012 - 01:08 PM

Again, this will be fixed in the next version.

#345 Sebra

  • Members
  • 726 posts

Posted 11 August 2012 - 03:22 PM

Hi!
Where can I change block ID?

#346 Corbald

  • Members
  • 19 posts

Posted 11 August 2012 - 03:39 PM

/.minecraft/config/arp.cfg. Mine is block 4095 by default, so I doubt any other mod is using that ID.

#347 Sebra

  • Members
  • 726 posts

Posted 11 August 2012 - 04:38 PM

The problem is I do not see arp.cfg anywhere. ;)/>
But got message about ID conflict at 235.
I'm using MultiMC if it helps.

Edit:
Now I found it, but where is BlockID 235?

Quote

java.lang.IllegalArgumentException: Slot 235 is already occupied by [email protected] when adding [email protected]
Where is no 235 in that file.

Edit again:
OK, found that too. Now just NPE:

Quote

java.lang.NullPointerException
at aan.<init>(SourceFile:42)
at AdditionalBuildcraftObjects.ABO.initialize(ABO.java:152)
at mod_AdditionalBuildcraftObjects.modsLoaded(mod_AdditionalBuildcraftObjects.java:31)
at cpw.mods.fml.common.modloader.ModLoaderModContainer.postInit(ModLoaderModContainer.java:362)
at cpw.mods.fml.common.Loader.postModInit(Loader.java:290)
at cpw.mods.fml.common.Loader.initializeMods(Loader.java:629)
at cpw.mods.fml.client.FMLClientHandler.onLoadComplete(FMLClientHandler.java:223)
at net.minecraft.client.Minecraft.a(Minecraft.java:429)
at net.minecraft.client.Minecraft.run(Minecraft.java:738)
at java.lang.Thread.run(Unknown Source)

Final Edit (I hope):
Removed BC API from .jar file - seems work now.

#348 Sebra

  • Members
  • 726 posts

Posted 11 August 2012 - 06:14 PM

View PostCorbald, on 26 July 2012 - 08:17 PM, said:

Also, fixed a bug in 'inventory-dump' program @ line 61:
local maxd = t.item.maxDamage
to

local maxd = stack.item.maxDamage
line 62 for me, but still needs to change.
And even then it shows good stuff as bad.

#349 Xfel

    Peripheral Designer

  • Members
  • 515 posts

Posted 12 August 2012 - 08:52 AM

The new version contains the fixes for that. I also brought the help files to the latest version.

For those who use the cable api: please redownload, I changed it's package for better structure.

#350 Sebra

  • Members
  • 726 posts

Posted 12 August 2012 - 09:11 AM

Dropbox shows error 404 :P/>

#351 Xfel

    Peripheral Designer

  • Members
  • 515 posts

Posted 12 August 2012 - 09:17 AM

uuups, was a typo

#352 Sebra

  • Members
  • 726 posts

Posted 12 August 2012 - 09:24 AM

Thanks.
Deleted BC2 API since I use BC3.

#353 Sparkst3r

  • New Members
  • 1 posts

Posted 12 August 2012 - 10:09 PM

Hi this not a crash bug but this gets spammed to my console when i open a computer with a workbench an allocator ect and the log change accordingly
its not serious but the log says its a bug so im posting it here as a bug :P/>

java.lang.RuntimeException: class xfel.mods.arp.common.TileDigitalWorkbench is missing a mapping! This is a bug!
at kw.b(TileEntity.java:70)
at xfel.mods.arp.common.TileAdvancedMachineBase.b(TileAdvancedMachineBase.java:41)
at xfel.mods.arp.common.TileDigitalWorkbench.b(TileDigitalWorkbench.java:170)
at aiv.a(AnvilChunkLoader.java:270)
at aiv.a(AnvilChunkLoader.java:107)
at ko.b(ChunkProvider.java:183)
at ko.a(ChunkProvider.java:231)
at xd.c(World.java:554)
at lb.a(SourceFile:71)
at lr.b(EntityRenderer.java:1125)
at net.minecraft.client.Minecraft.x(Minecraft.java:876)
at net.minecraft.client.Minecraft.run(Minecraft.java:753)
at java.lang.Thread.run(Unknown Source)


#354 sylphio

  • Members
  • 20 posts

Posted 13 August 2012 - 10:49 AM

Hello,

just a update on the 1.8.4, the version problem is fixed. Thank

The number of methods returned by the matter database and intervace inventory is still zero. so obviously the api fail.
the Workbench is working properly, Great thank

I the log i get the following error when i try to use any ARP block. (Bukkit mcpc version 1.7.7 (the one recommended to use with computercraft 1.4.1))

2012-08-13 06:21:44 [SEVERE] ALERT: SERIOUS BUKKIT PORTING ERROR. net.minecraft.server.ContainerPlayer (true) or xfel.mods.arp.common.ContainerDigitalWorkbench (false) is a container that does not provide a valid player and inventory to bukkit.
The mod porter needs to provide a player through getPlayer() and an IInventory through getInventory().
You may encounter issues. File a bug with this message at mcportcentral.co.za, please.
java.lang.Throwable
at net.minecraft.server.Container.transferTo(Container.java:39)
at org.bukkit.craftbukkit.event.CraftEventFactory.callInventoryOpenEvent(CraftEventFactory.java:491)
at net.minecraft.server.EntityHuman.openGui(EntityHuman.java:1336)
at xfel.mods.arp.common.BlockAdvancedMachine.interact(BlockAdvancedMachine.java:356)
at net.minecraft.server.ItemInWorldManager.interact(ItemInWorldManager.java:313)
at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:635)
at net.minecraft.serverhook.NetServerHandlerProxy.a(NetServerHandlerProxy.java:119)
at net.minecraft.server.Packet15Place.handle(SourceFile:39)
at net.minecraft.server.NetworkManager.b(NetworkManager.java:251)
at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:106)
at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:82)
at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:569)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:457)
at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
2012-08-13 06:30:07 [SEVERE] Could not pass event InventoryCloseEvent to ChestBank
org.bukkit.event.EventException
at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:304)
at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
at org.bukkit.plugin.TimedRegisteredListener.callEvent(TimedRegisteredListener.java:35)
at org.bukkit.plugin.SimplePluginManager.fireEvent(SimplePluginManager.java:482)
at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:467)
at net.minecraft.server.NetServerHandler.handleContainerClose(NetServerHandler.java:1059)
at net.minecraft.serverhook.NetServerHandlerProxy.handleContainerClose(NetServerHandlerProxy.java:192)
at net.minecraft.server.Packet101CloseWindow.handle(SourceFile:16)
at net.minecraft.server.NetworkManager.b(NetworkManager.java:251)
at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:106)
at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:82)
at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:569)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:457)
at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
Caused by: java.lang.NullPointerException
at forge.bukkit.ModInventoryView.getPlayer(ModInventoryView.java:34)
at org.bukkit.event.inventory.InventoryCloseEvent.getPlayer(InventoryCloseEvent.java:23)
at me.ellbristow.ChestBank.ChestBankListener.onInventoryClose(ChestBankListener.java:105)
at sun.reflect.GeneratedMethodAccessor109.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:302)
... 13 more

Thank you

#355 Xfel

    Peripheral Designer

  • Members
  • 515 posts

Posted 13 August 2012 - 05:26 PM

should be fixed now.

#356 sylphio

  • Members
  • 20 posts

Posted 13 August 2012 - 06:07 PM

Great thank ! I did a quick test of the new version :-).

I found 2 problems.

1- All the plugging files are located in the ARP subdirectory and not in the archive root so the plugging didn't load.

2- After a manually "re-base" of the zip file, the pluging still fail to load because the file /help/arpturtle.txt is missing for the archive

3- if i diff the lua file the type of the matter database is resource_database in server and database on the client. Is it normal?

if i fix the first 2 bug myself, the plugin load properly :-), i will do some functional test tonight.

Thank you and I hope i do not bug you too much with my bug report :-p

#357 Xfel

    Peripheral Designer

  • Members
  • 515 posts

Posted 13 August 2012 - 06:24 PM

Then you are not using the latest version.

#358 sylphio

  • Members
  • 20 posts

Posted 13 August 2012 - 06:49 PM

I am following the "bukkit" link on your first post.. Maybe the link is wrong?

https://dl.dropbox.c....2.5-bukkit.zip

If i redownload the file, i get exactly what i reported.

#359 Xfel

    Peripheral Designer

  • Members
  • 515 posts

Posted 14 August 2012 - 05:33 AM

Ah, I forgot to update the resources here. Thanks for noticing.

#360 sylphio

  • Members
  • 20 posts

Posted 14 August 2012 - 07:57 AM

Thank! The new version work lot better :-) and i no longer get any assert.

i retried using the new version on a clean bukkit server version MCPC 177 (No bukkit plugins, forge plugins : computer craft 1.41 + ARP only ) and the matter database / inventory still dont work.

I place a computer first and a matter database directly at his left

On the computer (after a forced computer reboot to be sure the api is loaded properly)
Lua
db.getItem("diamond")
Result : "no such method CheckItem"

For the inventory, any call will result in a error similar to "no such method IsInventoryValid"
Look like the peripheral didn't export his methods properly or crash while trying to do it.

The matter database is not essential because you can access the same functionnaly from the workbench that work properly but the inventory manager is a little bit more difficult to workaround.

Thank you for your help and i hope my feedback are useful.
Sylp.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users