Jump to content




[1.3?][SMP]Turtle - turtle.drop() causes items to duplicate.


11 replies to this topic

#1 lIlIlIIlll

  • Members
  • 15 posts

Posted 20 January 2013 - 07:17 AM

I think the version is 1.3 but I'm not sure to be honest. The server is running "3.1.3 - 1.2.5 Latest"


Example program:
for i=1,16 do

turtle.drop()

end


The turtle will select the slots, try to drop the items, but when it does: instead of dropping, the amount of items in the slot doubles.


The weird part: The problem is not always there, I have managed to get the turtles to drop their items.

#2 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 20 January 2013 - 07:25 AM

I can't think of any way that that could happen in our code - plus you're on an outdated version, which is bukkit based - e.g. not supported. If you can reproduce it on a later version (one for 1.4.6 or above) then I'll look into it.

#3 lIlIlIIlll

  • Members
  • 15 posts

Posted 20 January 2013 - 07:29 AM

View PostCloudy, on 20 January 2013 - 07:25 AM, said:

I can't think of any way that that could happen in our code - plus you're on an outdated version, which is bukkit based - e.g. not supported. If you can reproduce it on a later version (one for 1.4.6 or above) then I'll look into it.

Like I said, I'm not sure what version the server is running.

The turtles have 16 slots....

#4 lIlIlIIlll

  • Members
  • 15 posts

Posted 20 January 2013 - 07:35 AM

Posted Image

#5 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 20 January 2013 - 07:39 AM

Yes, I knew it was an outdated version. It is also a bukkit port - hence unsupported. Sorry, you're on your own.

#6 lIlIlIIlll

  • Members
  • 15 posts

Posted 20 January 2013 - 07:47 AM

View PostCloudy, on 20 January 2013 - 07:39 AM, said:

Yes, I knew it was an outdated version. It is also a bukkit port - hence unsupported. Sorry, you're on your own.

How is this version outdated? In the tekkit launcher you have to select "Latest" in order to play on the server...

Wait I have an idea, let's just say the version is outdated and not even investigate the issue... I'm sure I'm not the only one that is having this problem.

#7 lIlIlIIlll

  • Members
  • 15 posts

Posted 20 January 2013 - 08:32 AM

Anyone? Bump

#8 crazyguymgd

  • Members
  • 139 posts
  • LocationUSA

Posted 20 January 2013 - 08:54 AM

The "latest" version of tekkit does not use the latest version of ComputerCraft. And there is no point in looking into bugs in the old versions if they are not happening in the newest version.

#9 lIlIlIIlll

  • Members
  • 15 posts

Posted 20 January 2013 - 10:25 AM

No one uses the "newest" version, and there is no support for this on the bukkit forums.

Glad that you are all being so helpful!

:D

#10 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 20 January 2013 - 10:37 AM

Ok, let me put this in plain English so you can understand what I am saying, since your comprehension level seems to be sub-par.

The bukkit build of ComputerCraft in Tekkit is not official - it is not ported by me (I checked, and it isn't the latest port I did of ComputerCraft for 1.2.5). That makes it unsupported.

Next, even if it WAS ported by me (and I cannot stress enough that it is NOT, in ANY WAY endorsed by me) - it is outdated, and as such if there WAS an underlying ComputerCraft bug which caused this (which is unlikely, as I've NEVER had this reported), it is probably already fixed, unless you can reproduce that on the latest version.

TL;DR - not remotely an issue in Vanilla ComputerCraft.

#11 lIlIlIIlll

  • Members
  • 15 posts

Posted 20 January 2013 - 10:52 AM

So you don't have any idea as to why this would be happening? You can't even venture a guess to try and help someone out. Don't insult my intelligence.

Try some common courtesy.

to clarify:
I don't care that it is unsupported. If you are not going to be helpful then stop replying to this thread.

There are other people on this forum besides you.

#12 Cloudy

    Ex-Developer

  • Members
  • 2,543 posts

Posted 20 January 2013 - 10:54 AM

Yeah, but unlike most others, I can lock threads. Like so.

I'm not trying to be mean but this is not a place for tekkit bugs - that would be in the tekkit forums (and good luck with that)!

Should you wish to discuss this further, please feel free to PM me - but I doubt I could say much more that could help.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users