←  Ask a Pro

ComputerCraft | Programmable Computers for Minecraft

»

Computercraft crash issue

KaaaaasKop's Photo KaaaaasKop 26 Feb 2013

Hello everyone, I'm having a problem with ComputerCraft. It crashes after the Mojang screen and I can't get it to work.
I have already altered the block ID's so that there are no more conflicts (both computer and turtle ID's) yet I still get a crash message. (though a different one) I've read it several times to see if I could find a solution but I just can't understand it hehehe... So please, if you can give me an explanation for what is wrong and a solution you'd make my day, since this mod sounds awesome! I downloaded version 1.5.

Also I use Rei's minimap mod and Pixelmon mod, I have Minecraft Forge 6.6.0.497.

Crash message:

Minecraft has crashed!
----------------------
Minecraft has stopped running because it encountered a problem; Failed to start game
A full error report has been saved to C:\Users\Wesley\AppData\Roaming\.minecraft\crash-reports\crash-2013-02-25_15.19.57-client.txt - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(/>

--- BEGIN ERROR REPORT f22f7d14 --------
Full report at:
C:\Users\Wesley\AppData\Roaming\.minecraft\crash-reports\crash-2013-02-25_15.19.57-client.txt
Please show that file to Mojang, NOT just this screen!
Generated 25-2-13 15:19
-- System Details --
Details:
Minecraft Version: 1.4.7
Operating System: Windows 7 (x86) version 6.1
Java Version: 1.6.0_39, Sun Microsystems Inc.
Java VM Version: Java HotSpotâ„¢ Client VM (mixed mode), Sun Microsystems Inc.
Memory: 416194848 bytes (396 MB) / 519110656 bytes (495 MB) up to 1037959168 bytes (989 MB)
JVM Flags: 2 total; -Xms512m -Xmx1024m
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Suspicious classes: FML and Forge are installed
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP v7.26 FML v4.7.4.520 Minecraft Forge 6.6.0.497 7 mods loaded, 7 mods active
mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
mod_ReiMinimap [mod_ReiMinimap] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
ComputerCraft [ComputerCraft] (ComputerCraft1.5.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
CCTurtle [ComputerCraft Turtles] (ComputerCraft1.5.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
Pixelmon [Pixelmon] (Pixelmon 2.0.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
LWJGL: 2.4.2
OpenGL: AMD Radeon HD 6570M/5700 Series GL version 4.1.10834 Compatibility Profile Context, ATI Technologies Inc.
Is Modded: Definitely; Client brand changed to 'forge,fml'
Type: Client (map_client.txt)
Texture Pack: Default
Profiler Position: N/A (disabled)
Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
java.lang.NullPointerException
at ModTextureAnimation.a(ModTextureAnimation.java:119)
at com.pclewis.mcpatcher.mod.TextureUtils.registerTextureFX(TextureUtils.java:186)
at bba.a(RenderEngine.java:477)
at cpw.mods.fml.client.TextureFXManager.registerTextureOverrides(TextureFXManager.java:233)
at cpw.mods.fml.client.TextureFXManager.loadTextures(TextureFXManager.java:227)
at cpw.mods.fml.client.FMLClientHandler.onInitializationComplete(FMLClientHandler.java:247)
at net.minecraft.client.Minecraft.a(Minecraft.java:487)
at asq.a(SourceFile:56)
at net.minecraft.client.Minecraft.run(Minecraft.java:744)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 2c588d17 ----------
Quote

Lyqyd's Photo Lyqyd 26 Feb 2013

Split into new topic.
Quote

SuicidalSTDz's Photo SuicidalSTDz 26 Feb 2013

It looks to me as if one of the mods you are using isn't rendering an animation correctly. This crash is not due to ComputerCraft as far as I can tell.
Quote

KaaaaasKop's Photo KaaaaasKop 26 Feb 2013

View PostSuicidalSTDz, on 26 February 2013 - 09:43 AM, said:

It looks to me as if one of the mods you are using isn't rendering an animation correctly. This crash is not due to ComputerCraft as far as I can tell.

Yeah, I thought about that as well, but the strange thing is that I didn't get this error before I installed ComputerCraft, it was gone after I deleted it as well so that does kinda point the problem towards ComputerCraft right? What do you think I should do? I don't mind deleting rei's minimap but pixelmon has to stay because I play pixelmon with my sister. :P

Thanks for replying by the way. ^^
Quote

SuicidalSTDz's Photo SuicidalSTDz 26 Feb 2013

View PostKaaaaasKop, on 26 February 2013 - 11:08 AM, said:

View PostSuicidalSTDz, on 26 February 2013 - 09:43 AM, said:

It looks to me as if one of the mods you are using isn't rendering an animation correctly. This crash is not due to ComputerCraft as far as I can tell.

Yeah, I thought about that as well, but the strange thing is that I didn't get this error before I installed ComputerCraft, it was gone after I deleted it as well so that does kinda point the problem towards ComputerCraft right? What do you think I should do? I don't mind deleting rei's minimap but pixelmon has to stay because I play pixelmon with my sister. :P

Thanks for replying by the way. ^^
If you deleted ComputerCraft and it went away (Doubt it could be CC), then in theory it maybe, just maybe, that Pixelmon conflicts with it, since the error was an animation rendering. I would ask around with this error report (since i'm no expert obviously) and see what is wrong.

Glad I could be of some help ;) ^^
Quote

Lyqyd's Photo Lyqyd 26 Feb 2013

Try adding ComputerCraft back in and removing pixelmon. While your client is set up this way, do NOT load up any worlds with pixelmon items in them, as they would be lost forever.
Quote

KaaaaasKop's Photo KaaaaasKop 26 Feb 2013

View PostLyqyd, on 26 February 2013 - 11:33 AM, said:

Try adding ComputerCraft back in and removing pixelmon. While your client is set up this way, do NOT load up any worlds with pixelmon items in them, as they would be lost forever.

I did as you told me and deleted Pixelmon while adding ComputerCraft, I still get a crash message, I think it's the same one but not sure.


Minecraft has crashed!
----------------------
Minecraft has stopped running because it encountered a problem; Failed to start game
A full error report has been saved to C:\Users\Wesley\AppData\Roaming\.minecraft\crash-reports\crash-2013-02-26_01.28.07-client.txt - Please include a copy of that file (Not this screen!) if you report this crash to anyone; without it, they will not be able to help fix the crash :(

--- BEGIN ERROR REPORT 50adc97 --------
Full report at:
C:\Users\Wesley\AppData\Roaming\.minecraft\crash-reports\crash-2013-02-26_01.28.07-client.txt
Please show that file to Mojang, NOT just this screen!
Generated 26-2-13 1:28
-- System Details --
Details:
Minecraft Version: 1.4.7
Operating System: Windows 7 (x86) version 6.1
Java Version: 1.6.0_39, Sun Microsystems Inc.
Java VM Version: Java HotSpot™ Client VM (mixed mode), Sun Microsystems Inc.
Memory: 424693064 bytes (405 MB) / 519110656 bytes (495 MB) up to 1037959168 bytes (989 MB)
JVM Flags: 2 total; -Xms512m -Xmx1024m
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Suspicious classes: FML and Forge are installed
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP v7.26 FML v4.7.4.520 Minecraft Forge 6.6.0.497 6 mods loaded, 6 mods active
mcp [Minecraft Coder Pack] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
FML [Forge Mod Loader] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
Forge [Minecraft Forge] (coremods) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
mod_ReiMinimap [mod_ReiMinimap] (minecraft.jar) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
ComputerCraft [ComputerCraft] (ComputerCraft1.5.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
CCTurtle [ComputerCraft Turtles] (ComputerCraft1.5.zip) Unloaded->Constructed->Pre-initialized->Initialized->Post-initialized->Available
LWJGL: 2.4.2
OpenGL: AMD Radeon HD 6570M/5700 Series GL version 4.1.10834 Compatibility Profile Context, ATI Technologies Inc.
Is Modded: Definitely; Client brand changed to 'forge,fml'
Type: Client (map_client.txt)
Texture Pack: Sphax PureBDCraft 128x MC14.zip
Profiler Position: N/A (disabled)
Vec3 Pool Size: ~~ERROR~~ NullPointerException: null
java.lang.NullPointerException
at ModTextureAnimation.a(ModTextureAnimation.java:119)
at com.pclewis.mcpatcher.mod.TextureUtils.registerTextureFX(TextureUtils.java:186)
at bba.a(RenderEngine.java:477)
at cpw.mods.fml.client.TextureFXManager.registerTextureOverrides(TextureFXManager.java:233)
at cpw.mods.fml.client.TextureFXManager.loadTextures(TextureFXManager.java:227)
at cpw.mods.fml.client.FMLClientHandler.onInitializationComplete(FMLClientHandler.java:247)
at net.minecraft.client.Minecraft.a(Minecraft.java:487)
at asq.a(SourceFile:56)
at net.minecraft.client.Minecraft.run(Minecraft.java:744)
at java.lang.Thread.run(Unknown Source)
--- END ERROR REPORT 80f1b4a4 ----------
Quote

SuicidalSTDz's Photo SuicidalSTDz 26 Feb 2013

Wait, try loading your world without Sphax.

EDIT: You have MC Patcher installed? Possibly Pixelmon is not "interacting" with MC Patcher.
Quote

KaaaaasKop's Photo KaaaaasKop 26 Feb 2013

View PostSuicidalSTDz, on 26 February 2013 - 01:45 PM, said:

Are you sure CC is the only mod installed when you are doing this? Give us a list of ALL the mods installed currently. Wait, try loading your world without Sphax.

EDIT: You have MC Patcher installed? Most definately Sphax not rendering an item correctly

I switched texture pack to default then put ComputerCraft back in just to have it crash after mojang screen with same error message... Didn't actually delete Sphax from the textures map though if that's what you meant.

I'm using these mods:

Minecraft Coder Pack
Forge Mod Loader
Minecraft Forge
mod_ReiMinimap
Pixelmon
Quote

immibis's Photo immibis 26 Feb 2013

If your texture pack is 256x256 or more, try using Optifine instead of MCPatcher.

If your texture pack is 128x128 or less you shouldn't need either, as Forge supports these automatically.
Quote

SuicidalSTDz's Photo SuicidalSTDz 26 Feb 2013

It is most likely the fact the Pixelmon may not like MC Patcher

EDIT: Delete MC Patcher and install Optifine if the texturepack is higher than 128x128. Else, delete MC Patcher and that should work like Immibis said.
Quote

KaaaaasKop's Photo KaaaaasKop 26 Feb 2013

Hmmm... I'll try that later since I'm going to bed now, first chance I get I'll let you know if it worked, thanks for your support all of you so far. ^^
Quote

Sxw's Photo Sxw 26 Feb 2013

Another thing that may need to be done is update your mc forge, it updates quickly. :)
Quote

KaaaaasKop's Photo KaaaaasKop 27 Feb 2013

I got it to work by deleting MC Patcher, it works perfectly, now I just need to figure out what to do with the computers but I'll manage that probably hahaha. So thanks to anyone who helped me out! :D

View PostSxw, on 26 February 2013 - 05:09 PM, said:

Another thing that may need to be done is update your mc forge, it updates quickly. :)

Thanks, I'll keep that in mind. ^^
Quote