←  Operating Systems

ComputerCraft | Programmable Computers for Minecraft

»

[Off-Development]PockyOS v2.21 - Even more...

Poll: v2.2 poll (44 member(s) have cast votes)

Do ou like the update?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.

Is the current version buggy?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.

Should custom repos be my biggest priority for the next version?

You cannot see the results of the poll until you have voted. Please login and cast your vote to see the results of this poll.
Vote Guests cannot vote

GreenByteSoftware's Photo GreenByteSoftware 10 Jun 2014

Adding custom repos - the most difficult thing after encryption. Then adding some tweaks to UI or other stuff and releasing the update.
Remember, v2.2 will be beta testing build, that means it's supposed to have bugs. I cannot guarantee that 2.2 won't corrupt notes, tested in most of cases what I could imagine and fixed up every problem what I detected, but I'm pretty sure that I forgot something. Well... backup them first then update the OS. That would be cool to have couple testers.

Sorry guys, custom repos are going to come in 2.3 version. The reason: I want to begin a new application which connects pocket computers and desktop computers to do various stuff... actually I got bored of developing the same thing. The 2.2 version most likely coming out today and 2.3 in the next week (probably, but I may add other features so maybe at the end of the next week). I hope you will understand.

Packing the installer, get ready for the first beta!

The update is coming! Actually came out but now I'm editing this post

Now it's updated!
Quote

Konlab's Photo Konlab 11 Jun 2014

Cool update!
You must delete and re-create the poll if you want to be able voting.

I can translate to Hungarian.
PM me if you're interested with translation.
Quote

GreenByteSoftware's Photo GreenByteSoftware 13 Jun 2014

Finishing my new project called areaC, publishing in forums and then continuing pockyOS. Any bugs found? Please, let me know!
Quote

Konlab's Photo Konlab 14 Jun 2014

I have a bug:
If you update the OS from 2.15 to 2.2 then:
Choose 2.2 :P
If it says 'Set password?' then choose 'no' and if it reboots gives an error.
Quote

GreenByteSoftware's Photo GreenByteSoftware 14 Jun 2014

View Post_Konlab, on 14 June 2014 - 10:57 AM, said:

I have a bug:
If you update the OS from 2.15 to 2.2 then:
Choose 2.2 :P
If it says 'Set password?' then choose 'no' and if it reboots gives an error.
Well. The most unexpected bug what could happen. I didn't think that it would happen. Because seems no OS bugs found I will update OS with your translation and your found bug fix.
Quote

Konlab's Photo Konlab 15 Jun 2014

startup:maybe28:something with nil and string
Quote

GreenByteSoftware's Photo GreenByteSoftware 15 Jun 2014

View Post_Konlab, on 15 June 2014 - 11:21 AM, said:

startup:maybe28:something with nil and string
It happens when...(password set or not? version beta or not? typed correct pass or not?)
Quote

Konlab's Photo Konlab 15 Jun 2014

[attachment=1753:pockyos_bug1.JPG]

the latest testing version: v2.2
I don't set password
there is:
shell.run("pockyOS/..."..currentpass)
Bug: change currentpass to "currentpass" at end of line
Quote

Konlab's Photo Konlab 15 Jun 2014

Also another bug:

install from craftstore all the four things.
then try scrolling down: until you see only 'worm' and scroll up and there isn't the four installed things :(
Quote

Konlab's Photo Konlab 20 Jun 2014

The 2.2 update is still not released?
The 2.0 was very fast, and now it's slow?
I can't wait...
...Release!!!

Sorry :P
Quote

GreenByteSoftware's Photo GreenByteSoftware 24 Jun 2014

View PostKonlab, on 20 June 2014 - 02:21 PM, said:

The 2.2 update is still not released?
The 2.0 was very fast, and now it's slow?
I can't wait...
...Release!!!

Sorry :P
I was quite busy with learning openGL, now continuing pocky. First of all fixing the bugs(later today) then think of new features.
Quote

GreenByteSoftware's Photo GreenByteSoftware 24 Jun 2014

2.21 has been released! Less bugs - more smiles!
Quote

Konlab's Photo Konlab 24 Jun 2014

Yay! Version 2.21!!!
Also my name isn't KonLab bu Konlab :)

Quote

3.Added Hungarian translation by KonLab

:D

But anyways: cool update, I like this update :)
suggestions: Installing Notes/LuaIDE's files to apps folder without opening shell, with a App manager or with CrafStore would be good.
(I said this earlier, anyways) Setting a painting as background Image
Let have apps access to another places of OS (for example paintings/notes), but if you install an app, that has access there will a dialog pop-up with details (like in android if you download things from Play Store)
Quote

GreenByteSoftware's Photo GreenByteSoftware 24 Jun 2014

View PostKonlab, on 24 June 2014 - 10:51 AM, said:

Yay! Version 2.21!!!
Also my name isn't KonLab bu Konlab :)

Quote

3.Added Hungarian translation by KonLab

:D

But anyways: cool update, I like this update :)
suggestions: Installing Notes/LuaIDE's files to apps folder without opening shell, with a App manager or with CrafStore would be good.
(I said this earlier, anyways) Setting a painting as background Image
Let have apps access to another places of OS (for example paintings/notes), but if you install an app, that has access there will a dialog pop-up with details (like in android if you download things from Play Store)
I will add extended features of running notes/luaIDE projects in the 2.3 probably. Also the same with background, I will add two options: Built-in backgrounds and Paintings. I might add some kind of API to prevent entering into "pockyOS/" -> "system", "notes", "paintings" and also while trying to access notes/paintings it would prompt you if you are sure and if password set ask for the password. Maybe just everytime it launches the app. But now accessing notes would be nearly impossible without implementing some kinda methods of decrypting it because if you would look into code from startup file then main file you would understand that unhashed password is not saved anywhere and not accessible by anyone without modifying the OS. Anyways, talking about an API. It will be like pockyAPI.saferun(app, args, bla, bla, bla) this would make the unbrakable "chain" which actually check the program if it doesn't contain stuff like os.run, shell.run os.loadAPI and other stuff. Running programs should be changed to pockyAPI.seferun and os.loadAPI changed to pockyAPI.safeloadAPI() because API can run programs anyways for developers it can be easily implemented with text editor which can replace multiple stuff at once like ubuntu has gedit. I'm just thinking a lot on security, preventing viruses. As other guys can simply replace your OS file with another which will be able to send your real, unhashed password to their servers and most of people use their passwords the same everywhere and boom! All your stuff in other people hands. Well this API update is just idea and maybe later on once it's implemented I will call my pockyAPI not pockyAPI but pockyKernel.
Quote

Konlab's Photo Konlab 25 Jun 2014

You can change shell.run() and another these functions:
At startup if you have:
pockyAPI.run = shell.run
pockyAPI.loadAPI = os.loadAPI
shell.run = nil
os.loadAPI = nil

And if the program has some shell.run and things like this it will error
Quote

GreenByteSoftware's Photo GreenByteSoftware 25 Jun 2014

View PostKonlab, on 25 June 2014 - 10:14 AM, said:

You can change shell.run() and another these functions:
At startup if you have:
pockyAPI.run = shell.run
pockyAPI.loadAPI = os.loadAPI
shell.run = nil
os.loadAPI = nil

And if the program has some shell.run and things like this it will error
Oh, thanks! It also should work if I inject the code at the begining of program if it doesn't exists:
shell.run = pockyAPI.run
os.run = pockyAPI.run
os.loadAPI = pockyAPI.loadAPI
am I right?
Edited by thediamondgames, 25 June 2014 - 12:05 PM.
Quote

GreenByteSoftware's Photo GreenByteSoftware 26 Jun 2014

The next update will probably feature this bad boy usage
Edited by thediamondgames, 26 June 2014 - 08:24 PM.
Quote

Selim's Photo Selim 03 Jul 2014

Would you be able to make this run without needing access to http://pockyos.meximas.com/? I would like to use this on a server, but I cannot access the configs.
Quote

GreenByteSoftware's Photo GreenByteSoftware 04 Jul 2014

View Postbladze420, on 03 July 2014 - 11:50 PM, said:

Would you be able to make this run without needing access to http://pockyos.meximas.com/? I would like to use this on a server, but I cannot access the configs.
It should run without needing it, only craftstore and autoupdater won't work. You can pretty much download the folder of latest version, change in main systemfile the source of pockyOS sources to whatever you want like guthub and others, also is server yours or not? anyways to get it to other people server, find out tar archieve API somewhere on this forum, and I will attach the tar file of the latest version in this topic so people without editing config will be able to download the OS, anyways, if newer CC version will whitelist github by default, then things will be better, I mean I will move everything to github and everything will be fine. I don't put files to pastebin because there are quite many files and it would take me two days to just upload files because of pastebin limitations.
Quote

Tombot44's Photo Tombot44 15 Jul 2014

Going to use this and OneOs for the desktop. looked for ages to find a good OS.
Quote