←  Peripherals and Turtle Upgrades

ComputerCraft | Programmable Computers for Minecraft

»

[CC 1.33] [Beta 1.8.1] CCInput 0.27 (Big u...

djblocksaway's Photo djblocksaway 31 Mar 2012

i Love this addon because its so annoying trying to play worm on a monitor when u have to control it on the computer
This would be cool if dan200 added this into his next update :o/>
Quote

gigagames's Photo gigagames 31 Mar 2012

When i add this mod i became this error :
Spoiler
ok, id 160 is the problem i look in the mod_CCInput.cfg and see this :

#IBlockID (int:160,>=0,0,<=255,0) -- The blockId for IBlock
#KeyboardID (int:4272,>=0,0,<=1000000,0) -- The id for the keyboard
#IBlockName (java.lang.String:IBlock) -- The name for the IBlock
#KeyboardName (java.lang.String:Remote) -- The name for the remote
#
#Sat Mar 31 12:55:52 CEST 2012
KeyboardName=Remote
checksum=50odq2
IBlockID=160
IBlockName=IBlock
KeyboardID=4272

i change the IBlockID= to :
IBlockID = 199
but i became this error :

java.lang.IllegalArgumentException: Slot 160 is already occupied by [email protected] when adding [email protected]
at ox.<init>(Block.java:301)
why slot 160 ? i have change it to 199 wtf ? help me
Quote

Hackingroelz's Photo Hackingroelz 31 Mar 2012

View Postgigagames, on 31 March 2012 - 10:58 AM, said:

When i add this mod i became this error :
Spoiler
ok, id 160 is the problem i look in the mod_CCInput.cfg and see this :

#IBlockID (int:160,>=0,0,<=255,0) -- The blockId for IBlock
#KeyboardID (int:4272,>=0,0,<=1000000,0) -- The id for the keyboard
#IBlockName (java.lang.String:IBlock) -- The name for the IBlock
#KeyboardName (java.lang.String:Remote) -- The name for the remote
#
#Sat Mar 31 12:55:52 CEST 2012
KeyboardName=Remote
checksum=50odq2
IBlockID=160
IBlockName=IBlock
KeyboardID=4272

i change the IBlockID= to :
IBlockID = 199
but i became this error :

java.lang.IllegalArgumentException: Slot 160 is already occupied by [email protected] when adding [email protected]
at ox.<init>(Block.java:301)
why slot 160 ? i have change it to 199 wtf ? help me

Did you close Minecraft when editing the file? And are you sure you saved the file?
Quote

gigagames's Photo gigagames 31 Mar 2012

yes i close the file , and yes i have save it !
no i have change the id by the buildcraft mod when i no use the IBlock i became : "saving chunks" crach .. i have mc 1.2.3 and have dowload v. 0.252
Quote

Hackingroelz's Photo Hackingroelz 31 Mar 2012

View Postgigagames, on 31 March 2012 - 01:54 PM, said:

yes i close the file , and yes i have save it !
no i have change the id by the buildcraft mod when i no use the IBlock i became : "saving chunks" crach .. i have mc 1.2.3 and have dowload v. 0.252
Sorry, it was my fault, I made a mistake in the code. I'll release an update in a few minutes.

EDIT: for some reason I couldn't get the itemID to work, but the blockID should work now: http://adf.ly/6tH74
Quote

gigagames's Photo gigagames 31 Mar 2012

@roel15 thx for the update , it this for CC 1.3.1 and mc 1.2.3 ?
Quote

Hackingroelz's Photo Hackingroelz 31 Mar 2012

View Postgigagames, on 31 March 2012 - 07:31 PM, said:

@roel15 thx for the update , it this for CC 1.3.1 and mc 1.2.3 ?
Yes
Quote

gigagames's Photo gigagames 31 Mar 2012

Thank you made for me an update and even more for an older version

edit : i only need thits v. ?
Quote

gigagames's Photo gigagames 31 Mar 2012

i ts work half , its work and then i became saving chunks -.-
Quote

Hackingroelz's Photo Hackingroelz 01 Apr 2012

What error did you get ?
Quote

gigagames's Photo gigagames 01 Apr 2012

i onlie get "saving chunks" and then my minecraft becamen blackscreen
Quote

Hackingroelz's Photo Hackingroelz 01 Apr 2012

When do you get the black screen? When you try to load a save?
Quote

gigagames's Photo gigagames 01 Apr 2012

no
i have a world whit
my pc left from him ccsensor , right a monitor back from hin the iblock
when i load the map its ok i came in it 3-10 sec later saving chunks -> blackscreen when i delet you mod i doint became it
Quote

Hackingroelz's Photo Hackingroelz 01 Apr 2012

After using the same version of my mod you are using, I think I've figured it out. It seems like my mod is trying to see if the remote is on, even if the remote is not in the inventory. To make sure if this is the error, do you have an remote in you inventory when it crashes?
Quote

gigagames's Photo gigagames 01 Apr 2012

ähh
yes i have
Quote

Hackingroelz's Photo Hackingroelz 01 Apr 2012

Ok, I'll make an update then, it's not hard to fix.
Quote

gigagames's Photo gigagames 01 Apr 2012

i hope then its works xD
Quote

Hackingroelz's Photo Hackingroelz 01 Apr 2012

This should work:
http://adf.ly/6tH74
For some reason it decided to put 15 remotes in the creative inventory, but these are only different damage values, and not ID's
Quote

Hackingroelz's Photo Hackingroelz 01 Apr 2012

It seems like my new update crashes when queueEvent() is called...
Quote

Hackingroelz's Photo Hackingroelz 01 Apr 2012

Ok, I've tested it this one actually works:
http://adf.ly/6tH74
Quote