Jump to content




Client for OpenPeripheral's Glasses [0.5.2]


79 replies to this topic

#61 Xaviens

  • Members
  • 3 posts

Posted 19 March 2014 - 01:10 PM

 UNOBTANIUM, on 18 March 2014 - 11:46 PM, said:

That is weird. Cant reproduce the issue :(
Does someone else have the same problem Reggie descripes?
Yeah, having the same problem, OpenPeripheral 0.3.1, and Addons 0.1.1, when I attempt to push it through anyways, the program errors at line 1056, 356, or 690: attempt to concatenate string/number and nil. This is happening with all mod items attempted, including openblocks tanks, Thermal Expansion energy cells, Applied Energistics' ME Controller, I even exactly replicated what's shown in your image on the original post. I've tried just about everything I can think of, no luck.

#62 unobtanium

  • Members
  • 505 posts

Posted 20 March 2014 - 02:29 AM

Yeah all those errors are related to the method being not found and nil :S
Did something change in the newest version again?

#63 Xaviens

  • Members
  • 3 posts

Posted 20 March 2014 - 03:30 PM

 UNOBTANIUM, on 20 March 2014 - 02:29 AM, said:

Yeah all those errors are related to the method being not found and nil :S
Did something change in the newest version again?
To be more clear, the program shows the description/functionality of each method, but between the selection arrows, displays "nil". You can switch between the available methods freely, but selection results in the error. I haven't looked into how the API has changed, perhaps name retrieval was modified? I'll look into it.

#64 unobtanium

  • Members
  • 505 posts

Posted 22 March 2014 - 02:39 AM

Allright, i may found the mistake. Not sure thought, so i would recommand testing it out and if it works i release 0.5.1 so everybody can get the new working version :)

#65 Zeoic

  • Members
  • 12 posts

Posted 23 March 2014 - 07:02 PM

 UNOBTANIUM, on 22 March 2014 - 02:39 AM, said:

Allright, i may found the mistake. Not sure thought, so i would recommand testing it out and if it works i release 0.5.1 so everybody can get the new working version :)

When is going to be released? Im trying it out on FTB monster and like mentioned above it will not work with other energy storage devices.

#66 unobtanium

  • Members
  • 505 posts

Posted 24 March 2014 - 08:19 AM

It should be downloadable allready :S If you downloaded the "new version" from the 22 March and it doesnt work then it probably wasnt the fix :(

#67 blunty666

  • Members
  • 79 posts

Posted 24 March 2014 - 09:13 AM

I think I've managed to find the problem with the method name returning as nil. On lines 858 - 860 when you try to get the advanced methods data, you are trying to wrap the unit as a directly connected peripheral, instead of as a "net" peripheral. Using net.getTypeRemote(unit) and net.callRemote(unit, "getAdvancedMethodsData") seemed to work for me.

Spoiler

Also, on 871 when you insert the desired methods table "v" into the list table, the table "v" does not have a "name" index. Instead, "v" is indexed by its name in the table returned by getAdvancedMethodsData. I'm not sure I explained that too well so take a look at the code below.

Spoiler

Everything seems to work fine after that, hope this helps!

#68 unobtanium

  • Members
  • 505 posts

Posted 25 March 2014 - 03:02 AM

Wow thank you very much :D I replaced the code parts with yours.
I am sorry for all who are waiting for this program to work again, but my exams had higher priority.

I am wondering now, because i am sure that the "v" table had the "name" included. I remember that it was strange to have it exists as a variable in the table and as index as well.
I need to check this later but for now i use your code, which should work even if "name" exists allready in "v".

So i thank you once again :)

BETA 0.5.1
- fixed methods selection which made the whole program useless. (thanks to blunty666 for the fix)

#69 blunty666

  • Members
  • 79 posts

Posted 25 March 2014 - 08:05 AM

No problem, I'm glad to be able to help. Seems like an easy mistake to make, especially when even the mod authors have confessed to not knowing how their mod works!! :D

#70 Doom6197

  • Members
  • 3 posts
  • LocationSouth Africa

Posted 25 March 2014 - 09:53 AM

Good to hear its working again :D

#71 unobtanium

  • Members
  • 505 posts

Posted 26 March 2014 - 06:51 PM

Yop, i am happy to have it working again as well.

@blunty666: What do you mean with not knowing their own mod? That might be the case because the original creator has stopped working on it and other are keeping up the support.

Edited by UNOBTANIUM, 28 March 2014 - 05:13 PM.


#72 Mikeemoo

  • Members
  • 732 posts
  • LocationLondon, UK

Posted 26 March 2014 - 07:05 PM

 blunty666, on 25 March 2014 - 08:05 AM, said:

No problem, I'm glad to be able to help. Seems like an easy mistake to make, especially when even the mod authors have confessed to not knowing how their mod works!! :D

 UNOBTANIUM, on 26 March 2014 - 06:51 PM, said:

Yop, i am happy to have ti working again as well.

@blunty666: What do you mean with not knowing their own mod? That might be the case because the original creator has stopped working on it and other are keeping up the support.

I wish people would stop repeating that I've stopped working on OpenPeripheral. Where it's needed I contribute, just like anyone else in the team. My focus has been on other mods, but that doesn't mean I'm no longer working on OpenPeripheral.

Edited by Mikeemoo, 26 March 2014 - 07:46 PM.


#73 unobtanium

  • Members
  • 505 posts

Posted 26 March 2014 - 07:11 PM

ok :3

#74 blunty666

  • Members
  • 79 posts

Posted 26 March 2014 - 09:47 PM

I'm sorry if I have upset you, there was absolutely no malice intended in my comment, only a very poor sense of humour :( As you can see I'm new here and the last thing I want to do is stir up trouble.

OpenPeripheral is one of my favourite mods at the moment and I plan to continue using it, I might even get round to posting a glasses program I've been working on eventually... spoiler: animating objects in real-time!

#75 cojay24

  • New Members
  • 1 posts

Posted 27 April 2014 - 08:37 AM

Hello i love this mod and the terminal glasses however im new to the coding and all that and wanted to monitor the power of a batbox and used the code on here where i can customise it all myself but when its charged it does this help me please


Posted Image

#76 unobtanium

  • Members
  • 505 posts

Posted 28 April 2014 - 03:47 PM

I cant see the picture. Use e.g. imgur or an other picture hosting website.

#77 ShadowGar

  • Members
  • 13 posts

Posted 07 May 2014 - 09:24 AM

I'm currently using CC1.63 with Openperipheral snap shots for 1.6 and I'm getting an odd error with your script. So instead of explaining it, I took a video of it.

https://www.youtube.com/watch?v=tP6paL8qRIE


#78 unobtanium

  • Members
  • 505 posts

Posted 10 May 2014 - 02:51 AM

It is the new CC update. A lot broke and i am not ready to update all my programs right now. Maybe soon™

Edited by UNOBTANIUM, 10 May 2014 - 02:52 AM.


#79 adamjan2000

  • Members
  • 9 posts

Posted 29 January 2015 - 12:10 PM

When I want send message through rednet (Alarm) I can't change message! Why?

#80 unobtanium

  • Members
  • 505 posts

Posted 09 June 2015 - 09:17 PM

Updated the program to the newest version. (Tested in FTB Infinity)

Fixed adamjan2000's bug of not being able to edit the Rednet message.





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users